Electronics problems - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-24-2009, 01:10 PM   #1
Registered Member
Regular
 
Join Date: Apr 2009
Region: Georgia
Posts: 32
Electronics problems



Okay so I have TWO failed oxygen sensors on my 01 sixer. How does this happen simultaneously??? What may have cause it so I can go ahead and fix it? I've already bought two new sensors.

Also, my parking break warning light comes on whenever I give the car some gas or hit my regular breaks. Why??? what do I need to fix here?


Any help is appreciated.
mrjones3133 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-24-2009, 01:32 PM   #2
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: Electronics problems

it might be the sensor that checks the oxygen sensors or the actual sensors

I would see if the new sensors work and remove the light undo the negative battery terminal for a bit while you do the work so the computer resets

the parking brake light comes on probably due to your brake fluid is low this is probably true since when you hit the gas it comes on, mine did this after I bleed my brakes and forgot to top off the fluid (do not overfill fluid fill it to the fill line)
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 07-24-2009, 01:36 PM   #3
Registered Member
Regular
 
Join Date: Apr 2009
Region: Georgia
Posts: 32
Re: Electronics problems

I'll let you know what happens when I replace and top off everything this afternoon. Thanks.
mrjones3133 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-25-2009, 11:26 AM   #4
Registered Member
Regular
 
Join Date: Apr 2009
Region: Georgia
Posts: 32
Re: Electronics problems

I replaced one sensor, but the Bosch sensor i got to go on the passenger side cat converter was too long? It got stuck between the cat and the trans pan. I tried bending the exhaust a lil but it STILL was about a half inch too long? The light went off, even though the code it was throwing said both of them had failed. Anyways, I think I'm good.

The brake light was because of low fluid, I think its leaking on the rear passenger wheel

anyways, thanks again.
mrjones3133 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronics, Electronics, Electronics! Matt@StangMods Mustang Parts for Sale and Wanted 3 09-16-2005 10:29 AM
more problems charkelly9 Mustang Audio & Video 18 05-19-2005 08:22 PM
a/c problems Warfire80 1996-2004 Mustang GT 6 11-29-2004 05:52 PM
shouldn't the title be "electronics" ? dark ME Site Help & Announcements 12 04-29-2004 12:30 PM

» Like Us On Facebook



01:56 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.