Temperature problems - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-12-2009, 02:06 AM   #1
Registered Member
Regular
 
tvsr's Avatar
 
Join Date: Aug 2009
Region: Nevada
Posts: 122
Unhappy Temperature problems

I've fixed up my 1999 mustang really good since I bought 4 months ago. It was having problems with the 6th cylinder missfiring and changed the spark plugs with new factory set motorcraft plugs but now there's something wrong with the temerature. When I turn it on it doesn't heat up the needle doesn't even move even after 10 minutes letting it alone it won't go to the proper temperature, then when I drive it it starts heating up BAD. It overheats in about 15 minutes. There's coolant and the radiator has water in the cap but it still overheats.?? Does anybody know why? I was thinking I might need to replace the radiator cap as I've heard from another source but I don't think it's that.
tvsr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-12-2009, 02:24 AM   #2
Registered Member
Regular
 
tvsr's Avatar
 
Join Date: Aug 2009
Region: Nevada
Posts: 122
Re: Temperature problems

Quote:
Originally Posted by tvsr View Post
I've fixed up my 1999 mustang really good since I bought 4 months ago. It was having problems with the 6th cylinder missfiring and changed the spark plugs with new factory set motorcraft plugs but now there's something wrong with the temerature. When I turn it on it doesn't heat up the needle doesn't even move even after 10 minutes letting it alone it won't go to the proper temperature, then when I drive it it starts heating up BAD. It overheats in about 15 minutes. There's coolant and the radiator has water in the cap but it still overheats.?? Does anybody know why? I was thinking I might need to replace the radiator cap as I've heard from another source but I don't think it's that.
after the spark plug change the car was good to go then a few days later that's when the temperature problems came up
tvsr is offline   Reply With Quote
Old 08-12-2009, 02:37 PM   #3
Registered Member
Regular
 
Join Date: Apr 2007
Region: Alabama
Posts: 201
Re: Temperature problems

check your thermostat and make sure your radiator and grille aren't clogged/blocked by anything like leaves
ThaWill is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temperature sensor? falconplayer79 Pre-2005 V6 Mustang 10 12-24-2008 08:23 PM

» Like Us On Facebook



07:27 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.