Another bad track day - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-27-2005, 09:34 PM   #1
Road Trip!
 
Tbird232ci's Avatar
 
Join Date: Jun 2003
Region: Maryland
Posts: 1,170
Send a message via AIM to Tbird232ci
Another bad track day

Well...today was very interesting. I just put a new boost controller in the car last night, so i had 8psi to start with. I unbolted my catback, and did a few little things to prep for going to the track.

On the way to the track, the car was making a little bit of power, considering i was only running 8psi, 15psi is stock, but i didnt want to be making WOT passes on the street dialing in my boost, so i waited to do so untill i got to the track.

Get to the track, do a shakedown pass at 8psi, just to be sure that everything was ready to go, and to be sure my boost wasnt going to creep, or spike. That run was a 17.26 @ 81.5mph, for less than half the boost i wanted to run, not too bad, especially when the car ran 15psi stock, and they low 16's

My next pass, i was going to turn up the boost, and went to turn the boost controller, and the knob locked up or something...the thing was brand new, that shouldnt have been happening. So i took it apart, got the spring compressed enough to where it would screw properly, put it back in and hoped for the best. I launch the car, came out of the hole mean as hell, it hooked and it went. Midway through second, the turbo was making a nasty "airflow" sound, kinda like when you hear an air compressor hose get split, so i look over in that direction trying to figure out that sound, look at my boost guage, and the thing surpassed the 20psi mark and was pegged straight down, by the time i went to get my foot out of it, it blew the upper intake hose off. I limped the car over to the return lane, fixed the hose, and drove it back to the pits, after almost getting hit by a Chevelle who was flying down the return lane. Didnt get my time slip or anything, i was very interested in seeing my 60ft, but i got denied.

My third run, i got the boost turned down to about 13psi, which was still too low, but i wanted to run it before i went higher. Got up to the line, spun the water off my tires. Go to launch, and the car didnt make **** for power. Bogged the **** out of it, ran it through the gears, and it was a clean run, no problems during the run, untill i got my time slip. 17.1 @ 83mph

I dont know what it is, but my car really doesnt like the track, last time around, it was my fuel pump, this time, i dont know what it is yet. I have a list of stuff to look at and check, cam timing, ignition timing, intercooler hoses, all my vac lines, all that ****, so we'll see what happens.
Tbird232ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2005, 10:38 PM   #2
Registered Member
Regular
 
19ClearCobra96's Avatar
 
Join Date: Oct 2004
Region: Nebraska
Posts: 627
Send a message via AIM to 19ClearCobra96 Send a message via MSN to 19ClearCobra96
Re: Another bad track day

doesnt sound like a fun day
__________________
19ClearCobra96 is offline   Reply With Quote
Old 11-29-2005, 10:32 AM   #3
Road Trip!
 
Tbird232ci's Avatar
 
Join Date: Jun 2003
Region: Maryland
Posts: 1,170
Send a message via AIM to Tbird232ci
Re: Another bad track day

Turns out the lower intercooler hose blew off of its seat on the compressor housing, slid downward, and under vacume, it would seal, under boost, it was leaking

I also did some math, and found that if i got my 60ft down to a 1.9, even on the 8psi run, i would have ran a mid 15 or so
Tbird232ci is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TRACK DAY redcobravert General Mustang Discussion 7 08-17-2009 08:31 AM
Private Track day in GA 5.0ttop Regional Mustang Discussion 0 09-25-2007 12:03 PM
This guy is having a bad day... A really, really bad day JROC The Bar 15 08-16-2007 11:52 PM
Track Day 7/14 MarkuzLS1 Regional Mustang Discussion 26 07-16-2006 01:03 AM
track day strike1980 Pre-2005 V6 Mustang 10 01-09-2006 11:33 AM

» Like Us On Facebook



01:07 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.