Engine problems!?!?!?!? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-13-2010, 02:29 PM   #1
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Engine problems!?!?!?!?

OK, so three times now a wrench light apperared next to my speedometer, and when it does my engine runs really rough, and my gas pedal just basicaly stops working. Aftet happening today i realized it happens after everytime i fill my gas tank. The only mod i have done to it is duels, but since i have more air flow will that make my engine run "lean" if im not running a high octane?? Now, im not sure what that means but ive herd the term used when taking about air fuel mixtures. PLEASE give me your input on what this could be!!!
Blackbandit is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-13-2010, 02:38 PM   #2
15.3 Second V8 Killer Yo
Legacy
Regular
 
PureVenom's Avatar
 
Join Date: Aug 2004
Region: Louisiana
Posts: 7,212
Send a message via AIM to PureVenom Send a message via MSN to PureVenom Send a message via Yahoo to PureVenom
Re: Engine problems!?!?!?!?

Wow....there are a lot of details we will need here.

Your engine isn't running lean now because of your duals unless something went wrong hooking up your O2 sensors or you disconnected something and didn't put it back together right and now have a bad leak.

And octane rating has nothing to do with running rich and/or lean.

Ok, with those details cleared up....what car do you have? Year? Model?

Does this light stay on for a while when it comes on? If so, go fill up, drive to a local autozone, oreilly's, or advanced auto and they will scan your car for error codes which will then tell you exactly what is wrong.
__________________
"When I know more, I'll be forthcoming. Or I won't be forthcoming, and I'll be honestly deceptive." - Les Miles
PureVenom is offline   Reply With Quote
Old 07-13-2010, 04:06 PM   #3
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Re: Engine problems!?!?!?!?

the details: 2005 v6 mustang (4.0), 5 speed with 31500 miles. Now when the light comes on i turn the car off, and the turn it back on and then its fine. So the light will only stay on untill it restart it.......as far as i know cause when it happens i immedialy restart it. What do you think??
Blackbandit is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-13-2010, 04:55 PM   #4
Registered Member
Regular
 
ponyboy94's Avatar
 
Join Date: Mar 2010
Region: Illinois
Posts: 109
Re: Engine problems!?!?!?!?

I had the same problem with a differant car when fueling. What I found out was make sure the car is shut off when fueling, do not try to top off the tank just fill it and make sure u turn your cap acouple of times past lock. This solved my problem I know how it sounds but it has to do with breathing and vapor lock. I never had a problem ever again. Ponyboy
ponyboy94 is offline   Reply With Quote
Old 07-13-2010, 05:20 PM   #5
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Re: Engine problems!?!?!?!?

well, i went to auto zone and when they ran the scan two codes came back. One said i had a faulty throttle boddy or its stuck closed and or bad connecions, and the other said: defective app sensor, multiple control system failure detected, or failed ECM....So i guess i should go to the ford dealer????
Blackbandit is offline   Reply With Quote
Old 07-14-2010, 05:17 PM   #6
Registered Member
Regular
 
Zebs5408's Avatar
 
Join Date: Mar 2009
Region: Georgia
Posts: 800
Re: Engine problems!?!?!?!?

NOOOOO...not yet, i believ the intake could be a problem, could be a throttle cable sticking or something but that usually make the gas pedal floored lol,,,anyway my first thought was fuel pump or injectors....are u filling the car ALL the way up? like clicking eveyr cent into it?
__________________
04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)


03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Old 07-14-2010, 06:03 PM   #7
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Re: Engine problems!?!?!?!?

Well when i fill it i usally "basicaly" fill it but not squeezing every cent. I called the dealership today and they were going to charge me 92 bucks to run a dianostic, But your saying not to....What should i do???
Blackbandit is offline   Reply With Quote
Old 07-14-2010, 11:47 PM   #8
Registered Member
Regular
 
ponyboy94's Avatar
 
Join Date: Mar 2010
Region: Illinois
Posts: 109
Re: Engine problems!?!?!?!?

I think I would clear the code and drive it and see what happens the next time you put in gas and see if it does it again we had codes that didn't make sence and it didn't happen again, it sounds wierd but it worked. Good luck ponyboy
ponyboy94 is offline   Reply With Quote
Old 07-15-2010, 09:45 PM   #9
Registered Member
Regular
 
Zebs5408's Avatar
 
Join Date: Mar 2009
Region: Georgia
Posts: 800
Re: Engine problems!?!?!?!?

Sorry i haven got back to u quicker i apologize,,, ive heard of people feeling the car to much and damaging the purge solenoid, i googled it to make sure but couldnt get a Defnent answer, but regardless i agree clear the codes and try it again, 100 bucks to just figure out what the problem is is retarded, try some fuel injector clearer ir octane booster! just tyr it and dont fill up ALL the waym when it click leave it alone dont round off to the dollar! keep me posted
__________________
04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)


03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Old 07-15-2010, 11:23 PM   #10
Registered Member
Regular
 
Join Date: Jun 2010
Region: California
Posts: 50
Re: Engine problems!?!?!?!?

First I would invest in an SCT tuner, that has a built in diagnostic tool so you can read and clear codes in your driveway. If throttle body is one of the problems American Muscle has one from BBk, brand new throttle body, for I believe 269.00. Easy to install. As far as the other code goes not so sure. I agree with the others though, DO NOT GO TO DEALER YET, clear the codes and try it again...Good luck!
Camaro Eater is offline   Reply With Quote
Old 07-16-2010, 06:18 AM   #11
Registered Member
Regular
 
Zebs5408's Avatar
 
Join Date: Mar 2009
Region: Georgia
Posts: 800
Re: Engine problems!?!?!?!?

im gonna rule the throttle out on this one....but dont quote me lol...sonic where u at he usually chimes in on these....i still think it might have something to do with fuel delivery!
__________________
04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)


03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Old 07-16-2010, 11:44 AM   #12
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Re: Engine problems!?!?!?!?

Well i filled up yesterday, and it did not fail on me!! But i found out the dianostic check will be covered under warrenty, so i think ill do it anyway since i dont have to pay. BUt i do think its probaly something dumb like the gas cap not venting good. I really really appretiate all the help, and after i get th diagnostic i will let you guys know how it works out.
Blackbandit is offline   Reply With Quote
Old 07-17-2010, 08:26 AM   #13
Registered Member
Regular
 
Zebs5408's Avatar
 
Join Date: Mar 2009
Region: Georgia
Posts: 800
Re: Engine problems!?!?!?!?

OH SWEET YES UTILIZE EVEYRTHING WHILE ITS UNDER WARRANTY....if u have any problems or think anything might become a problem get it check while its under warranty,,,,i remember my warranty......its been so long...i miss her, i should have never let her go
__________________
04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)


03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Old 07-17-2010, 05:32 PM   #14
Road Trip!
 
Join Date: Apr 2008
Region: Texas
Posts: 521
Send a message via AIM to VCS_SSSTANG
Re: Engine problems!?!?!?!?

Quote:
Originally Posted by Zebs5408 View Post
NOOOOO...not yet, i believ the intake could be a problem, could be a throttle cable sticking or something but that usually make the gas pedal floored lol,,,anyway my first thought was fuel pump or injectors....are u filling the car ALL the way up? like clicking eveyr cent into it?

Correct me if i'm wrong, but isn't the 2005 v6 Drive By wire?

@blackbandit, yes if its under warranty buy all means take it in and let ford fix whatever is wrong before you get stuck with a bill later down the road. Let us know how it goes
VCS_SSSTANG is offline   Reply With Quote
Old 07-19-2010, 01:56 PM   #15
Registered User
Newbie
 
Join Date: Jul 2010
Posts: 6
Re: Engine problems!?!?!?!?

Thanks so much for the help you guys, i will have an awnser tomorrow after i take it to ford. Hopefully its nothing major, but my warrenty should cover it anyway . And i planned on getting a sct tunner before all this started happening anyway.
Blackbandit is offline   Reply With Quote
Old 07-19-2010, 02:08 PM   #16
Registered Member
Regular
 
Join Date: Aug 2009
Region: Other
Posts: 344
Re: Engine problems!?!?!?!?

100 I made it .. no longer a newb
__________________
!
zztop1234 is offline   Reply With Quote
Old 07-20-2010, 02:53 PM   #17
Registered Member
Regular
 
Zebs5408's Avatar
 
Join Date: Mar 2009
Region: Georgia
Posts: 800
Re: Engine problems!?!?!?!?

Quote:
Originally Posted by zztop1234 View Post
100 I made it .. no longer a newb
LOL bless ur heart
__________________
04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)


03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery/engine/oil leakeage problems? blackhawk Pre-2005 V6 Mustang 2 01-09-2010 06:50 AM
Engine noise from COLD engine 03GreyMach1 1996-2004 Mustang GT 10 03-14-2008 08:40 PM
engine swap 1989 to 1992 4 cyl engine dannyc1992 General Mustang Discussion 0 02-08-2008 02:59 PM
Engine Swap/ Engine Shakes too_cool_mitch Pre-2005 V6 Mustang 2 02-28-2006 03:01 PM
a/c problems Warfire80 1996-2004 Mustang GT 6 11-29-2004 05:52 PM

» Like Us On Facebook



06:28 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.