Starter not working? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-15-2010, 12:08 PM   #1
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Starter not working?

So I go to start my car today, and it doesn't start. The first time it tried a little, but then it starts clicking. Click, click, click until I let off the key. Sadly, I do not think it is the battery because my headlights are bright, and I can still play music and power two amps.

Yesterday I disassembled my push to start button so I could take pictures for installation and repaint my trim pieces. I am positive that all the wires are put back right, so it is not that. However, yesterday I did try to start the car several times because it wasn't turning over. (come to find out I didn't have the wire harness plugged in) but after I plugged it in I started the car just fine.

Now there is today... won't start at all. Thoughts? Did I kill the starter? What is this going to cost me?
blue-saleen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2010, 12:39 PM   #2
Registered Member
Regular
 
hottcobra's Avatar
 
Join Date: May 2007
Region: Louisiana
Posts: 2,638
Re: Starter not working?

First off you need to try to jumpstart the car. If it still won't start. Then start looking at other options.
__________________

2006 Mustang GT lots of mods ex wife has it
1979 corvette stingray #'s matching 47K org. miles
1970Chevelle SS 454 big block Old School 500hp Sold
hottcobra is offline   Reply With Quote
Old 07-15-2010, 01:05 PM   #3
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Re: Starter not working?

I tried the jump, nothing. It still just clicks.
blue-saleen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2010, 09:38 PM   #4
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Re: Starter not working?

Fixed it, it was a fuse
blue-saleen is offline   Reply With Quote
Old 07-15-2010, 09:41 PM   #5
Registered Member
Regular
 
Jordan's Avatar
 
Join Date: Mar 2010
Region: Massachusetts
Posts: 229
Re: Starter not working?

Don't you love that? You think its something bad and its something tiny like that.
__________________
Red 1998 Mustang V6 5-Speed. Flowmaster True Dual Glasspack Exhaust, AM Cold Air Intake, Black Chrome Cobra 17x9 fronts, 17x10.5 rears, short throw shifter, rear bumper inserts, billet grill top and bottom with pony insert, chrome shorty antenna, chrome shift knob, halo headlights-HID's 8000k, smoked fog lights-HID's 8000k, custom radio and speakers, Eibach Pro-Kit lowering springs
Jordan is offline   Reply With Quote
Old 07-16-2010, 11:21 AM   #6
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Re: Starter not working?

Yeah, first time EVER! Every time something goes wrong a buddy of mine always asks, "don't you wish you got a civic?" psh, civic.
blue-saleen is offline   Reply With Quote
Old 07-19-2010, 09:24 PM   #7
Registered Member
Regular
 
Jordan's Avatar
 
Join Date: Mar 2010
Region: Massachusetts
Posts: 229
Re: Starter not working?

Civics blow
__________________
Red 1998 Mustang V6 5-Speed. Flowmaster True Dual Glasspack Exhaust, AM Cold Air Intake, Black Chrome Cobra 17x9 fronts, 17x10.5 rears, short throw shifter, rear bumper inserts, billet grill top and bottom with pony insert, chrome shorty antenna, chrome shift knob, halo headlights-HID's 8000k, smoked fog lights-HID's 8000k, custom radio and speakers, Eibach Pro-Kit lowering springs
Jordan is offline   Reply With Quote
Old 07-19-2010, 09:48 PM   #8
Registered Member
Regular
 
sonicpony03's Avatar
 
Join Date: Dec 2007
Location: WI
Region: Wisconsin
Posts: 5,411
Re: Starter not working?

Ha, I was going to suggest a fuse...a while ago I tore my center console area/auto shifter assembly apart and yanked out the O/D wires. I re-wired them, hooked them up to a 2 position switch, put everything back together and it didn't work. I was ticked, then I checked the fuse...it was blown

All the headache and frustration for a shifter boot I might add.
__________________


12 Black GT500 SVT PP l VMP TVS l JLT123 l O/R X l 28x11.50Rx15 M/T Street R's l BMR Suspension l Recaros

03 Sonic Blue 3.8 / 17 Magnetic Fusion Sport 2.7 EB
sonicpony03 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
starter issue? jimmy_beaner 1996-2004 Mustang GT 5 01-04-2009 05:53 PM
starter 95gt45 1979-1995 Mustang GT 5 05-30-2008 07:53 PM
starter, battery, or other????? sledgehammer Pre-2005 V6 Mustang 5 04-11-2008 12:18 PM
Starter wkndpaintballer Pre-2005 V6 Mustang 21 03-01-2007 03:21 PM
Remote Starter Help Justin 1979-1995 Mustang GT 2 11-28-2006 07:05 AM

» Like Us On Facebook



07:03 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.