alternators..... - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-23-2003, 09:49 PM   #1
Registered Member
Join Date: Jul 2003
Posts: 27
Send a message via AIM to sp33d

guys, ive burned up 3 alternators in like a month...

whats the deal? i have a 900w sound system but i use it sparingly. and i noticed today when i turned my heat on high the battery dial dropped like 2 letters. should i get a beafer alternator? my mechanic said he wouldnt be able to honor my alternators warranty anymore since hes replaced it so much now... guys got any ideas?

btw, i got a 98.

sp33d is offline   Reply With Quote
Old 10-23-2003, 09:54 PM   #2
Legacy Member
Join Date: May 2003
Posts: 1,895
Send a message via AIM to Rellik Send a message via Yahoo to Rellik
What exactly is going on?
When you are driving what happens?
Does your car not hold a charge? Does the RPM's stop moving and drop completely.
Is the battery (alternator) light on in the dash?

That shouldnt be happening. There is more to this that your mechanic isnt caring to find out. 3 alternators and he just keeps switching them, not cool.

Check your alternator fuse.
This article will show you.

Also test the alternators wiring harness.
I would also get a trained and certified auto electrical technition (ahem )
to check out your wiring.

Also have you tested your battery? You might want to look into a optima battery.
Check your grounds clean them up make sure your alternator is grounded correctly.

Theres tons of things. He shouldnt of just replaced 3 alts..................... with out testing anything. :no:

Rellik is offline   Reply With Quote
Old 10-24-2003, 06:25 AM   #3
Legacy Member
lowflyn's Avatar
Join Date: Aug 2003
Region: Mississippi
Posts: 19,855
Send a message via AIM to lowflyn
I'm running 1000 watts through my stock alternator and it holds up. Amps don't even waver, it's something besides your alternator dude, hate to say it.
"I'm not driving too fast...just flying too low"
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
90 7up vert - new project-07 DSG Focus -DD
lowflyn is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

10:50 AM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 is in no way associated with or endorsed by Ford Motor Company.