95 mustang problems - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-11-2011, 11:43 AM   #1
Registered User
Newbie
 
Join Date: Jan 2011
Region: Iowa
Posts: 11
95 mustang problems

Hey I'm new to this forum but it seems like a pretty cool place. Anyway I have a 95 stang and iv change the thermostat, water pump, and power steering pump on this thing. The problem I'm running into is the heat gauge keeps pegging out on me. Iv dropped the fluids out of it like 3 times and bled the thermostat like iv been told to do and it still overheats. Anyone else ever have this problem??

Zach
Zachinnis is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2011, 12:18 PM   #2
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: 95 mustang problems

maybe its a bad sensor / is it over heating ?
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 01-11-2011, 12:21 PM   #3
Registered User
Newbie
 
Join Date: Jan 2011
Region: Iowa
Posts: 11
Yes. I let it run for a bit and it just pegs out
Zachinnis is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2011, 12:41 PM   #4
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: 95 mustang problems

hmm do you hear the T-Stat open and fluid pump? Sounds like its got air in the system if the t-stat is opening up etc.

you can get ford to vacuum the system and let fluid get sucked back in~

the stock gauge on temp works in your year actually if I remember right, but its not super accurate. You can use another gauge to double check the real temp to make sure its not just a bad sensor.
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 01-11-2011, 12:48 PM   #5
Registered User
Newbie
 
Join Date: Jan 2011
Region: Iowa
Posts: 11
Actually I don't. And the hoses going in are cold. And the ones out are scalding hot
Zachinnis is offline   Reply With Quote
Old 01-11-2011, 03:10 PM   #6
Registered Member
Regular
 
Thegabrielles's Avatar
 
Join Date: Jan 2011
Region: Georgia
Posts: 26
Re: 95 mustang problems

Open up the radiator cap and see if the antifreeze if flowing, mkae sure and open it when its cold, then wait until it gets to operating temp and see if it is "flowing" through the radiator. Seems to me that you may still have a bad thermostat. I think it would be fairly simple to diagnose in person, pain in the neck on here.

If the hoses coming out are hot and the ones going in are cold your antifreeze is not flowing. Another possibility is the wrong water pump! I cant remember what years they changed directions, seems like it was back in the 80's but if you got the wrong one it would definitely be a problem. Maybe someone else can chime in, been a long time since I worked on the 80's, 90's models.
__________________
2011 Roush Stage 2 Convertible Race Red with black stripes, Charcoal Interior
Roush # 11-0306,Roush Front and Rear Brake Kit, Roush Exhaust with Square tips, 20" wheels with Cooper Tires Roush Billet Grille matching lower 3 piece, Matte Black side and top stripes, White Face Gauge cluster, Convertible Light Bar
Purchased 27Dec2010
Thegabrielles is offline   Reply With Quote
Old 01-11-2011, 10:37 PM   #7
Registered User
Newbie
 
Join Date: Jan 2011
Region: Iowa
Posts: 11
It's all the way to the top next to the cap :/ my guess is that it needs flushed. I was hoping that I wouldn't have to do that.
Zachinnis is offline   Reply With Quote
Old 01-11-2011, 10:53 PM   #8
Registered Member
Regular
 
Thegabrielles's Avatar
 
Join Date: Jan 2011
Region: Georgia
Posts: 26
Re: 95 mustang problems

Its at teh top, but is it moving? You need to remove the cap, start it u and wait to see if the antifreeze is flowing through the radiator. Flushing may be necessary, but if its not flowing something else needs to be done first.
__________________
2011 Roush Stage 2 Convertible Race Red with black stripes, Charcoal Interior
Roush # 11-0306,Roush Front and Rear Brake Kit, Roush Exhaust with Square tips, 20" wheels with Cooper Tires Roush Billet Grille matching lower 3 piece, Matte Black side and top stripes, White Face Gauge cluster, Convertible Light Bar
Purchased 27Dec2010
Thegabrielles is offline   Reply With Quote
Old 01-11-2011, 10:57 PM   #9
Registered User
Newbie
 
Join Date: Jan 2011
Region: Iowa
Posts: 11
It comes flyin out when the cap is removed haha. When u press on the accelerator it goes back down though.
Zachinnis is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
65 mustang problems Dmay65 Classic Mustangs 0 01-03-2011 07:49 PM
02 Mustang Possible Transmission Problems TK225 General Mustang Discussion 3 10-07-2008 07:41 AM
Problems with 1991 Mustang GT wmsoccer28 1979-1995 Mustang GT 10 08-20-2007 10:48 PM
mustang problems?? MarcyWK Pre-2005 V6 Mustang 7 05-08-2006 01:54 PM
What problems have you had with your mustang? mstnglvr The Bar 20 07-09-2004 11:02 AM

» Like Us On Facebook



12:11 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.