Problem with tube to Water pump! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-11-2011, 06:52 PM   #1
Registered User
Newbie
 
Join Date: Apr 2011
Region: Kentucky
Posts: 7
Unhappy Problem with tube to Water pump!

Hey guys!

Having a little trouble here.

Just got a new water pump, and it's doing fine. But the metal tube that runs from it to the heater core I think? Well, it's leaking right at the connection to the water pump.

We tried glueing it and everything but it still seeps through.

I absolutely can NOT find this tube, and I'm not sure if I even know the name for it. It would be nice to be able to replace it somehow. No junkyards around here have it. And I can't find it on the net neither.

Any kind of help would be wonderful please!

Thanks in advance!
shipwreckedsoul is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-11-2011, 10:11 PM   #2
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: Problem with tube to Water pump!

Is there anyway you can get a picture or find a picture of what you're talking about? I'm trying to picture it in my head...and just can't remember that exact setup.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 04-12-2011, 12:42 AM   #3
Road Trip!
 
Join Date: Dec 2010
Region: Other
Posts: 2,268
I know this tube you speak of. Have you tried Latemodel Restoration Supply? They might have one.
93CobraGuy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2011, 08:42 PM   #4
Registered User
Newbie
 
Join Date: Apr 2011
Region: Kentucky
Posts: 7
Re: Problem with tube to Water pump!

Sorry it took so long to repost!
Here's the photos! Sorry about the blurriness, Kinda a cheap camera.


This picture runs all the way into the motor and like I said weve tried gasket glue and everything. I'd love to be able to get a new one.

Hope you guys can help!

It's a 3.8L btw.
shipwreckedsoul is offline   Reply With Quote
Old 04-15-2011, 01:55 PM   #5
Registered User
Newbie
 
Join Date: Apr 2011
Region: Kentucky
Posts: 7
Re: Problem with tube to Water pump!

Guys, not to be a bother but I really need some help with this.
shipwreckedsoul is offline   Reply With Quote
Old 04-15-2011, 02:05 PM   #6
Road Trip!
 
Join Date: Dec 2010
Region: Louisiana
Posts: 1,635
Quote:
Originally Posted by shipwreckedsoul
Guys, not to be a bother but I really need some help with this.
Replace the tube and the seal. Clean all silicone from sealing surfaces.
Alscobra is offline   Reply With Quote
Old 04-15-2011, 02:28 PM   #7
Road Trip!
 
Join Date: Dec 2010
Region: Other
Posts: 2,268
If you can't get a new tube, take that one off and have someone else at a shop weld it for you.
93CobraGuy is offline   Reply With Quote
Old 04-19-2011, 09:45 AM   #8
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: Problem with tube to Water pump!

Damn, I wish I could provide instant help but when I'm cruising EBay for V6 parts there are several cars being parted out that want you to call them for something specific. That is a perfect photo to reference. They would have no doubt what part you are indicating.
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 04-19-2011, 06:15 PM   #9
Registered User
Newbie
 
Join Date: Apr 2011
Region: Kentucky
Posts: 7
Re: Problem with tube to Water pump!

Hey guys! Thanks for all the responses!
Actually, I was able to get the tube I needed. It was the tube than ran from the water pump, under the intake, and then to the heater core hose.
I finally found a salvage yard that had a cougar engine with the pipe on it. So I'm assuming the previous owner dropped one of those down in it.
shipwreckedsoul is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump Bolts audi_b Pre-2005 V6 Mustang 3 08-30-2009 02:34 AM
Water Pump Bypass Tube Rainman64 1979-1995 Mustang GT 1 07-19-2009 10:52 PM
water pump ? jumpman1203 Pre-2005 V6 Mustang 0 10-16-2006 01:25 AM
Water pump took a dump KyleUSAF Pre-2005 V6 Mustang 16 01-25-2006 02:35 PM
electric water pump? widowvirgin Pre-2005 V6 Mustang 15 07-01-2004 04:30 PM

» Like Us On Facebook



01:05 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.