Did a search but no luck... - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-16-2007, 09:49 PM   #1
Registered Member
Regular
 
crazeflier07's Avatar
 
Join Date: Feb 2005
Region: Florida
Posts: 274
Send a message via AIM to crazeflier07
Did a search but no luck...

Had the light come on, Check Engine, and plugged my code reader in and got the Fuel Air Metering P1151 code. This isnt the first time the light has come on so I know that it isnt going to take my car out of commission but Iwas curious what you guys have done. I ran a search on the forum but there wasnt any responses to what people have done. There was one about getting a new MAF but I was wondering if there would be anything else that would be doing something to make the light come on. Any help would be great. Thanks!
~Jon~
__________________

Sinister Six
1998 3.8L V6
Done So Far:
~CAI, True dual exhaust, UDPs, MGW Shifter, H&R springs, Stage 1 & 2 supension kit, performance rotors & pads, steel braided lines, 1 inch rear spacers, A.R. Rebel 17x9s with BFG rubber! :thumbs2:
crazeflier07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-16-2007, 09:52 PM   #2
Legacy Member
Legacy
 
Kiljosh's Avatar
 
Join Date: Oct 2004
Region: Pennsylvania
Posts: 1,282
Send a message via AIM to Kiljosh
Re: Did a search but no luck...

Clean the thing with electrical contact cleaner and see if that helps after a reset on your battery, 15 minutes leave it disconnected. Could be dirty if you just recharged your filter.
__________________
Kiljosh is offline   Reply With Quote
Old 08-17-2007, 10:27 PM   #3
Registered Member
Regular
 
crazeflier07's Avatar
 
Join Date: Feb 2005
Region: Florida
Posts: 274
Send a message via AIM to crazeflier07
Re: Did a search but no luck...

Possible O2 sensor failure? How much do they run.
~Jon~
__________________

Sinister Six
1998 3.8L V6
Done So Far:
~CAI, True dual exhaust, UDPs, MGW Shifter, H&R springs, Stage 1 & 2 supension kit, performance rotors & pads, steel braided lines, 1 inch rear spacers, A.R. Rebel 17x9s with BFG rubber! :thumbs2:
crazeflier07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-18-2007, 08:16 PM   #4
Legacy Member
Legacy
 
Kiljosh's Avatar
 
Join Date: Oct 2004
Region: Pennsylvania
Posts: 1,282
Send a message via AIM to Kiljosh
Re: Did a search but no luck...

No Im talking about your mass air sensor. I believe that is what this code relates to but I could see it being o2's as well just because of the name of the code..
__________________
Kiljosh is offline   Reply With Quote
Old 08-19-2007, 12:36 PM   #5
Registered Member
Regular
 
crazeflier07's Avatar
 
Join Date: Feb 2005
Region: Florida
Posts: 274
Send a message via AIM to crazeflier07
Re: Did a search but no luck...

Well I took the intake apart and cleaned out the mass air, connections, and the intake piping and got myself a nice new K&N filter and stuck it in there but the lights still on. Probably just time to take her in and get her tuned and looked over. Thanks for the help Kiljosh.
~Jon~
__________________

Sinister Six
1998 3.8L V6
Done So Far:
~CAI, True dual exhaust, UDPs, MGW Shifter, H&R springs, Stage 1 & 2 supension kit, performance rotors & pads, steel braided lines, 1 inch rear spacers, A.R. Rebel 17x9s with BFG rubber! :thumbs2:
crazeflier07 is offline   Reply With Quote
Old 08-19-2007, 04:56 PM   #6
Legacy Member
Legacy
 
Kiljosh's Avatar
 
Join Date: Oct 2004
Region: Pennsylvania
Posts: 1,282
Send a message via AIM to Kiljosh
Re: Did a search but no luck...

by no means am I an expert but it was worth a shot right?
__________________
Kiljosh is offline   Reply With Quote
Old 08-21-2007, 06:47 PM   #7
Registered Member
Regular
 
crazeflier07's Avatar
 
Join Date: Feb 2005
Region: Florida
Posts: 274
Send a message via AIM to crazeflier07
Re: Did a search but no luck...

Well I put some fresh fuel in it and the light went off today so maybe it was just some bad fuel but at least the MAF and filter are all clean and good to go. Thanks bro!
~Jon~
__________________

Sinister Six
1998 3.8L V6
Done So Far:
~CAI, True dual exhaust, UDPs, MGW Shifter, H&R springs, Stage 1 & 2 supension kit, performance rotors & pads, steel braided lines, 1 inch rear spacers, A.R. Rebel 17x9s with BFG rubber! :thumbs2:
crazeflier07 is offline   Reply With Quote
Old 08-22-2007, 12:41 PM   #8
Registered Member
Regular
 
dapack69's Avatar
 
Join Date: Jul 2003
Region: Florida
Posts: 114
Send a message via Yahoo to dapack69
Re: Did a search but no luck...

It takes a while for the light to turn off as well, does not go off immedialty.
__________________
I have a bone stock steering wheel.

http://www.gotstang.com/profile.php?dapack69#jump
dapack69 is offline   Reply With Quote
Old 08-22-2007, 05:01 PM   #9
Registered Member
Regular
 
bullitt482's Avatar
 
Join Date: Apr 2006
Region: Mississippi
Posts: 1,106
Re: Did a search but no luck...

Actually, if you disconnected the battery, it should not come back on unless a new problem arises that makes the light come on... Like what was previously said.
__________________
01 Bullitt
bullitt482 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you search through ME? bullitt482 The Bar 12 06-18-2007 12:14 PM
My Search is complete Danger Dude The Bar 9 03-15-2006 07:20 AM
Job search 04V6STANG Regional Mustang Discussion 2 03-11-2005 01:20 PM
OASIS Search? 03GreyMach1 The Bar 2 08-15-2004 02:28 PM

» Like Us On Facebook



09:27 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.