Alternator? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-16-2011, 05:28 PM   #1
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Alternator?

Ok. I had an isse last week with my car not starting because two wires to the battery were loose. Fixed em but now whenever I drive my battery light seems to still stay on.
Is it a bad alternator or is it different wires or what?
bradh2414 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2011, 07:21 PM   #2
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
Quote:
Originally Posted by bradh2414
Ok. I had an isse last week with my car not starting because two wires to the battery were loose. Fixed em but now whenever I drive my battery light seems to still stay on.
Is it a bad alternator or is it different wires or what?
Most likely an alternator.. Might want to pick up a tester at a parts store. They're not much and you can check the battery with the car off and you can check the alternator by hooking the red to the positive and the black to the negative while it's running. I'll see if I can find a link and show you...or I could do a quick video..?
Qwik Four Six is offline   Reply With Quote
Old 07-16-2011, 10:13 PM   #3
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Thanks man. I tested it an saw it wasn't charging. So I followed the wires and found out they were loose. Tightened them up and reconnected the alternator and the light came off
bradh2414 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2011, 11:52 PM   #4
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
That's good. How about that new thermostat?
Qwik Four Six is offline   Reply With Quote
Old 07-17-2011, 09:30 AM   #5
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Quote:
Originally Posted by Blb97stang
That's good. How about that new thermostat?
Good. Took longer than expected. It also made me realize that I might not have a 98 engine. The auto yard said itcwas but now it's iffy
bradh2414 is offline   Reply With Quote
Old 07-17-2011, 10:43 AM   #6
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
Quote:
Originally Posted by bradh2414

Good. Took longer than expected. It also made me realize that I might not have a 98 engine. The auto yard said itcwas but now it's iffy
Ohhh. Dang.
Qwik Four Six is offline   Reply With Quote
Old 07-17-2011, 10:52 AM   #7
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Quote:
Originally Posted by Blb97stang

Ohhh. Dang.
Yeah the older newer engines have an oring seal the thermostat housing but this still had a paper gasket
bradh2414 is offline   Reply With Quote
Old 07-17-2011, 11:32 AM   #8
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
Quote:
Originally Posted by bradh2414

Yeah the older newer engines have an oring seal the thermostat housing but this still had a paper gasket
Oh. Well as long as it runs good.
Qwik Four Six is offline   Reply With Quote
Old 07-17-2011, 02:31 PM   #9
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Exactly.
bradh2414 is offline   Reply With Quote
Old 07-17-2011, 02:52 PM   #10
Registered Member
Regular
 
goherd's Avatar
 
Join Date: Jul 2011
Posts: 79
Quote:
Originally Posted by bradh2414
Exactly.
I have already replaced mine. Only have 33,000 and change on the engine
goherd is offline   Reply With Quote
Old 07-17-2011, 11:00 PM   #11
Registered Member
Regular
 
bradh2414's Avatar
 
Join Date: May 2011
Region: Massachusetts
Posts: 727
Quote:
Originally Posted by goherd

I have already replaced mine. Only have 33,000 and change on the engine
Well i think it's good now. I won't be upset if it does go now since i'm kinda expecting it
bradh2414 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:04 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.