Help me - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-21-2011, 03:56 AM   #1
Registered User
Newbie
 
Join Date: Aug 2011
Region: New York
Posts: 2
Help me

Got a 2003 3.8 stang can't find the damn coolant sensor
Khanboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2011, 12:12 AM   #2
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
You mean temperature sending unit?
Qwik Four Six is offline   Reply With Quote
Old 08-22-2011, 01:56 AM   #3
Registered User
Newbie
 
Join Date: Aug 2011
Region: New York
Posts: 2
Cts like after my stang gets to normal temp every 4 or 5 mins fan keeps coming on. I clean the radiator 2 times Buh yet it still comes on and when it comes on shakes the whole freaking car. It's getting me really pissed off
Khanboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2011, 10:05 AM   #4
Registered Member
Regular
 
Qwik Four Six's Avatar
 
Join Date: Nov 2010
Region: South Carolina
Posts: 882
Hmm.. Lemme think.
Qwik Four Six is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.