Urgent Electrical Help Needed - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-20-2011, 01:13 PM   #1
Registered User
HFerrari13's Avatar
Join Date: Sep 2011
Region: Illinois
Posts: 4
Urgent Electrical Help Needed

Hello everyone,

I need some urgent help with my 96 v6 mustang. This is my first post and this car is my first so please bear with me as I try to explain my situation as best as possible.

I installed four new speakers in my car and realized my rear driver side speaker created no noise. I took out the stereo and found a black square wire harness, around 2 inches long which had the purple, green, and grey wires which I believe meant they were for the speakers. Inside the harness the color wire that correlates with the rear driver side speaker was loose so I figured that was my only problem. I replaced the harness wire for wire and am now having major problems.

When I went to start the car after installing the new harness my ignition switch slipped all the way, no resistance and no reaction from the engine. I removed the key and the car acted like the key was still in the ignition, all the lights were on and stereo was working. Nothing would get the lights to shut off short of unplugging the battery. My electronic door opener does not work either.

Another weird response is now with my stereo plugged in I tested to see if the harness at least fixed the problem. I am getting perfect sound from my driver side speakers and nothing from my passenger. And to make this more confusing. When I slide my balance from right to left, it is reversed. So right balance is working my driver's side which is the only side that works.

I have had experience working with electrical wires in the past and am fairly certain all my connections are solid. I am just baffled how all this could happen from one simple harness.

The only other information that I think is relevant is that this car appeared to be all wired up for an amplifier. I have a switch to turn it on in the cabin and the wires in my trunk. Connected to the stereo are two extra harness which do not connect into anything.

Thank you for bearing with my on this long post. Any response would be greatly appreciated.

HFerrari13 is offline   Reply With Quote
Old 10-21-2011, 08:07 AM   #2
Registered Member
kickerofdoom's Avatar
Join Date: Mar 2011
Region: Maryland
Posts: 1,859
Your rear speaker don't work because the missing amps. Just get rid of it and go aftermarket and around 200 you can have a great sound system

kickerofdoom is offline   Reply With Quote
Old 10-26-2011, 10:59 AM   #3
Registered User
HFerrari13's Avatar
Join Date: Sep 2011
Region: Illinois
Posts: 4
I'm sorry if I wasn't clear but my rear speakers work fine. I am having an electrical problem. Basically when the battery leads are connected the car responds as if the key is in the ignition. Which means if I start the car, which I still can, there is no way to shut it off, unless I hit the fuel pump button in the trunk. Any help would be greatly appreciated as I really don't want to have to take this to a mechanic.

P.S. I put in a new ignition lock and that changed nothing.
HFerrari13 is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

« tuners | Regulator »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.0 tuning help needed! 5.0Stangman 1979-1995 Mustang GT 4 10-20-2011 01:10 AM
Building a computer tower... input needed jimmy_beaner The Bar 52 09-06-2011 09:48 PM
Drivers side power mirror needed?! nickcap Mustang Parts for Sale and Wanted 3 08-29-2011 12:49 AM
SN95 fender needed! mustangbill00 Mustang Parts for Sale and Wanted 6 08-15-2011 03:09 AM
Police officer probably needed new pants after this Brent Pictures and Videos 9 07-25-2011 04:06 AM

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

11:49 PM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.