I think I destroyed my car? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-22-2011, 10:55 PM   #1
Registered User
Newbie
 
Join Date: Oct 2011
Region: Tennessee
Posts: 12
I think I destroyed my car?

So, here is the story. My buddy was running at me with some popcorn. He was outside my car and I was inside it. So I started it and threw it into reverse(it's an auto). I revved without letting it get into gear, I guess, and then the tranny a bit and it sounded like it was dying, so I quickly put it into park and turned it off. Now, whenever I start my car, it starts just fine, but the idle slowly does down until it dies. I can give it gas to bring it back, though. I just need opinions? Did I destroy my car?
Skinny Jeans is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-23-2011, 02:16 AM   #2
Registered Member
Regular
 
Ruthless's Avatar
 
Join Date: Sep 2011
Region: Texas
Posts: 122
Highly doubt it don't sweat it. I remember my dads truck doing that once minus the whole reverse part. But I think it was something simple like a throttle position sensor or something... If the car can run and drive then you didn't totally destroy it.
Ruthless is offline   Reply With Quote
Old 10-23-2011, 06:12 AM   #3
Registered Member
Regular
 
mystang50's Avatar
 
Join Date: Jul 2011
Location: houston
Region: Texas
Posts: 1,201
Re: I think I destroyed my car?

Quote:
Originally Posted by Ruthless View Post
Highly doubt it don't sweat it. I remember my dads truck doing that once minus the whole reverse part. But I think it was something simple like a throttle position sensor or something... If the car can run and drive then you didn't totally destroy it.
+1
__________________
1995 5.0 u/d,cai,t/b,shorty headers,x pipe,flows 40's,373 gears, alum. driveshaft, alum. radiator, shift kit, e-cam, ported upper and lower intake, 100 shot of spray, 2100 stall, black 0304 cobras. suspension: upper and lower control arms, sub frame connecters, and springs all SVE
mystang50 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-23-2011, 07:01 AM   #4
Registered Member
Regular
 
ForsakenProto's Avatar
 
Join Date: Jun 2011
Region: North Carolina
Posts: 1,143
Re: I think I destroyed my car?

had this problem in my stepdads maxima, his rear bank cam sensor had gone out and after being replaced never had the issue again. If its putting out a code, get it read and change out the sensor as soon as possible. (it wont say rear or anything since the maxima is DOHC and our cars are not)
ForsakenProto is offline   Reply With Quote
Old 10-23-2011, 08:35 AM   #5
Registered Member
Regular
 
Beav's Avatar
 
Join Date: Feb 2011
Region: Kansas
Posts: 565
Re: I think I destroyed my car?

You definitely destroyed your car....












I am kidding..... Sounds like something minor... Just keep the popcorn away from your car... Good luck getting it squared away...
__________________

07 Roush 427R, Brembo 14" rotor and four piston calipers

05 GT Mustang, FRPP, FR X pipe, Hurst short throw,
American Racing Torque Thrust 10X20 wheels,
Granettelli tower brace, custom painted flat black grafix, Yellow Optima
Beav is offline   Reply With Quote
Old 10-23-2011, 09:23 AM   #6
Registered Member
Regular
 
ForsakenProto's Avatar
 
Join Date: Jun 2011
Region: North Carolina
Posts: 1,143
Quote:
Originally Posted by Beav
You definitely destroyed your car....

I am kidding..... Sounds like something minor... Just keep the popcorn away from your car... Good luck getting it squared away...
Just think of all the butter on the paint! And if you thought having a piece of a kernel in your teeth was bad, imagine how it feels when it's stuck in your paint. OH THE HUMANITY!?! D:
ForsakenProto is offline   Reply With Quote
Old 10-24-2011, 07:29 PM   #7
Registered Member
Regular
 
Ruthless's Avatar
 
Join Date: Sep 2011
Region: Texas
Posts: 122
Any update?
Ruthless is offline   Reply With Quote
Old 10-25-2011, 08:49 AM   #8
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: I think I destroyed my car?

never EVER drop it down into Reverse or Drive while the rpms are high
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 10-27-2011, 07:04 AM   #9
Registered Member
Regular
 
mystang50's Avatar
 
Join Date: Jul 2011
Location: houston
Region: Texas
Posts: 1,201
Quote:
Originally Posted by SpectorV
never EVER drop it down into Reverse or Drive while the rpms are high
What?whats wrong with netural dropin it? lol
__________________
1995 5.0 u/d,cai,t/b,shorty headers,x pipe,flows 40's,373 gears, alum. driveshaft, alum. radiator, shift kit, e-cam, ported upper and lower intake, 100 shot of spray, 2100 stall, black 0304 cobras. suspension: upper and lower control arms, sub frame connecters, and springs all SVE
mystang50 is offline   Reply With Quote
Old 10-27-2011, 08:28 AM   #10
Registered Member
Regular
 
bryanbrock's Avatar
 
Join Date: Sep 2010
Region: Florida
Posts: 185
Re: I think I destroyed my car?

take it to ford and pay the 50 bucks to get it properly diagnosed than fix it yourself. not doing anything about it will not fix it, and driving it the way it is may cause stress on other parts you are unaware of and make the situation worse, and trust me I have seen other guys do it a million times.
bryanbrock is offline   Reply With Quote
Old 10-27-2011, 10:22 AM   #11
Registered Member
Regular
 
ColeJohnson's Avatar
 
Join Date: Jan 2011
Location: Ketchikan, Alaska
Region: Louisiana
Posts: 2,507
Quote:
Originally Posted by bryanbrock
take it to ford and pay the 50 bucks to get it properly diagnosed than fix it yourself. not doing anything about it will not fix it, and driving it the way it is may cause stress on other parts you are unaware of and make the situation worse, and trust me I have seen other guys do it a million times.
I can't stress that enough. If your car is acting up, don't keep driving. Seriously.
__________________

2016 Comp Orange GT (current)
Aurora - 2002 Boosted GT! (Sold, sadly)
ColeJohnson is offline   Reply With Quote
Old 10-27-2011, 09:18 PM   #12
Registered Member
Regular
 
Ruthless's Avatar
 
Join Date: Sep 2011
Region: Texas
Posts: 122
+1,000,001!!!!! You can probably take it to Autozone and they should be able to put the scanner on it and tell you what's wrong. Or possibly look it up online I'm sure it has happened to someone else already who has posted a fix.
Ruthless is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fast car andyr421 1996-2004 Mustang GT 28 11-13-2011 06:08 PM
97 GT Smelling gas fumes in car Sharky97 1996-2004 Mustang GT 2 09-20-2011 03:54 PM
99 V6 3.8L 115,000 miles Mustang Car Problems *PLEASE HELP* LONG STORY 99Mustang Pre-2005 V6 Mustang 7 09-13-2011 02:43 AM
Big problem-easy find, small problem-hard to find Dnraiders General Mustang Discussion 0 08-30-2011 12:10 PM
Car not staying charged Jettin Stang 1979-1995 Mustang GT 16 08-17-2011 11:12 PM

» Like Us On Facebook



12:56 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.