98 v6 mustang electrical probs - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-24-2011, 07:53 PM   #1
Registered Member
Regular
 
insomniac717's Avatar
 
Join Date: Dec 2011
Region: Pennsylvania
Posts: 42
98 v6 mustang electrical probs

My v6 98 mustang has an after market head unit and had it in for a good 6 months no problems except now when I turn of my car it stays on and now it doesn't turn on at all and my remote clicker doesn't unlock or lock my car and when I unlock my car from inside my head lights turn on and my speedometer doesn't work
insomniac717 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-24-2011, 08:23 PM   #2
Registered Member
Regular
 
Justasix98's Avatar
 
Join Date: Dec 2011
Location: Norman, Oklahoma
Region: Oklahoma
Posts: 370
Pull out the head unit, and check all the wiring. Every inch of it. And your headlights/head unit/speedo not coming on problem, check the fuseblock under the dash on the far left side. I remember when I hooked mine up (I had to re-wire literally everything, and I mean everything) my car wouldn't start, not even turn over. Checked all my wiring, replaced the fuse and bam, problem solved. The head unit had a bad ignition wire, causing it to arc out and pop the fuse. Btw I own a 98' as well.
__________________
Just A Sixxer!
Proud member of WickedStangs Okc Chapter!
Justasix98 is offline   Reply With Quote
Old 12-26-2011, 10:27 PM   #3
Registered Member
Regular
 
insomniac717's Avatar
 
Join Date: Dec 2011
Region: Pennsylvania
Posts: 42
Okay you were right about the fuse but my head unit still doesn't turn off and my speakers turn on and off
insomniac717 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2011, 12:11 AM   #4
Registered Member
Regular
 
Justasix98's Avatar
 
Join Date: Dec 2011
Location: Norman, Oklahoma
Region: Oklahoma
Posts: 370
Quote:
Originally Posted by insomniac717
Okay you were right about the fuse but my head unit still doesn't turn off and my speakers turn on and off
Your head unit not turning on/off. Pull out the head unit. From the car harness, there's a solid red wire (+ constant power) and a solid yellow wire (+ ignition). Reverse these 2 wires going to the head unit. That should fix the problem.
Glad I can help..
__________________
Just A Sixxer!
Proud member of WickedStangs Okc Chapter!
Justasix98 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Tags
v6 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What mods can get 350+hp? Johnstonb93 2005-2010 V6 Mustang 101 11-06-2017 12:25 PM
1969 Mustang Coupe Restoration Project yellow99 Classic Mustangs 5 10-15-2011 11:05 AM
1995 Mustang SVT Cobra Project yellow99 1979-1995 Mustang GT 0 09-03-2011 06:51 PM
1971 Mustang Fastback Project yellow99 Classic Mustangs 0 09-03-2011 06:49 PM

» Like Us On Facebook



01:46 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.