engine acting weird - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-02-2012, 03:25 AM   #1
Registered Member
Regular
 
Kamakanani0's Avatar
 
Join Date: Nov 2010
Region: California
Posts: 27
engine acting weird

So just got my car from local shop took it to replace old transmission because it was slipping and now a new one so all good...No! When I picked it up and drove out my engine sounded like popcorn popping as I tried to accelerate scared out my mind and to add to that there's a grinding noise like a pipe dragging but there's nothing hanging.... oh and engine was running ok before I had brought it in to change the transmission. So I called the mechanic and said what's going on he said its misfiring? If my cars misfiring what could it be ?
Kamakanani0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2012, 05:54 AM   #2
Registered Member
Regular
 
back n a stang's Avatar
 
Join Date: Oct 2011
Region: North Carolina
Posts: 903
Re: engine acting weird

Was it mis-firing b4 you took it in? Is the car modded? Sounds like your car may have been abused.Just sayin..
__________________
2012 Prem. w/ GB insert stripe/stitch , M6,Brembo, 3.73,Stock Air-Box,93-R Tune,Borla Catback w/ X-Pipe,FRPP-"K" Springs,BMR PH Bar,BMR Upper support brace,BMR Reloc. Brackets,CHE Lca's, Koni Struts/Shocks, Jlt cc,Saleen grill, Hydrocarbon Center console/stereo surround,Formula One Tint, MGW w/ speedawg ball match seat inserts,SOS Dual Aeroforce Guages,MT82 Amsoil MTF.METCO Uca/Ucm, Shaftmasters DS
back n a stang is offline   Reply With Quote
Old 01-02-2012, 10:48 AM   #3
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: engine acting weird

Take a look at the plug wire diagram. The ignition coil.
The 3.8L V6 engines.... 1/5, 2/6, 3/4- That is how it should be connected to the ign. coil.
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2012, 11:52 AM   #4
Registered Member
Regular
 
Kamakanani0's Avatar
 
Join Date: Nov 2010
Region: California
Posts: 27
Quote:
Originally Posted by back n a stang
Was it mis-firing b4 you took it in? Is the car modded? Sounds like your car may have been abused.Just sayin..
Nope engine was fine I had it for a year and the previous owner told I just needed to do basic maintenance and to change the oil pan gasket ... when I bought it it was 160,000 miles now its at 174,000 been a year since I bought it. Nope all stock I have flowmasters that's about it

---------- Post added at 09:52 AM ---------- Previous post was at 09:48 AM ----------

What you mean abuse?
Kamakanani0 is offline   Reply With Quote
Old 01-05-2012, 01:33 PM   #5
Registered Member
Regular
 
V6 stang's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 2,252
Abused as in he rode the **** outta it? Lol or treated your engine badly when working on it.
__________________
"Hp sells cars, Tq wins races" - Carroll Shelby... RIP
2012 Mustang GT Convertible
Roush Exhaust

2003 Mustang GT (Sold)
1999 35th Anniversary V6(SOLD)
V6 stang is offline   Reply With Quote
Old 01-05-2012, 05:59 PM   #6
Registered Member
Regular
 
Kamakanani0's Avatar
 
Join Date: Nov 2010
Region: California
Posts: 27
Quote:
Originally Posted by V6 stang
Abused as in he rode the **** outta it? Lol or treated your engine badly when working on it.
Oh man lol
Kamakanani0 is offline   Reply With Quote
Old 01-05-2012, 10:08 PM   #7
Registered Member
Regular
 
Join Date: Sep 2011
Region: California
Posts: 25
Re: engine acting weird

You never know with shops. I had engine rebuilt in Nissan Quest by P&G in Rialto, CA. When I got it back it was awesome & under hood looked brand new. Beautiful work & Alex is the best. When my Grand Marquis let loose took to place in Riverside, CA. When picked up it barely ran. Plug wires ziptied together. Vacuum hoses hooked up wrong. Filthy. When it got hot, smell was surprising. Doing a transmission isn't easy. Make sure nothing got disconnected. If they pressure washed before or after make sure all is dry. These systems misfire if wet in certain spots.
earthdeth is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Myths about "back-pressure" Eturner General Mustang Discussion 45 09-08-2016 02:31 PM
Engine seized! 2012 gt 5.0 8WOOD 2011-2014 Mustang GT 94 12-01-2011 01:39 AM
99-04 Mustang GT ENGINE BLOWN!!! HELP!!! FORDGT14 1996-2004 Mustang GT 17 09-16-2011 03:11 PM
Engine died at low speed. Could not start engine in hot weather Ucla1998 Pre-2005 V6 Mustang 5 08-09-2011 03:15 AM
3.8l to 4.6l engine swap important steps zrider07 General Mustang Discussion 2 08-04-2011 10:07 PM

» Like Us On Facebook



06:24 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.