Problem with electrical system - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-29-2007, 01:38 PM   #1
Registered User
Newbie
 
Join Date: Nov 2007
Posts: 3
Exclamation Problem with electrical system

I was wondering if anyone can help me with my 2001 V6 stang. A couple of days ago all electrical system just shut off. No lights, horn, or anything. Car won't start and sometimes radio would flicker on and off. The only thing that I can see working is the THEFT light. I tried both keys knowing about the chip in them, but still nothing. The clicker also won't open or lock the car. I got the battery checked and it was good. I am thinking the alarm system won't disengage for some reason. I just don't know what to do anymore, help please!!!
kitslik is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2007, 03:03 PM   #2
Registered Member
Regular
 
sledgehammer's Avatar
 
Join Date: Nov 2007
Region: Colorado
Posts: 344
Send a message via Yahoo to sledgehammer
Re: Problem with electrical system

My alarm system went recently too. I couldnt start it or control anything electrical. I am no expert, but check the inline fuse for the alarm. my fuse was bad. it seemed to fix things.
__________________
94 v6 manual, 3.45s w/t-lock, cai, straight straight through dual exhaust, sct eliminator.
sledgehammer is offline   Reply With Quote
Old 11-29-2007, 06:46 PM   #3
Registered User
Newbie
 
Join Date: Nov 2007
Posts: 3
Re: Problem with electrical system

can you please tell me where that fuse is located?
kitslik is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2007, 10:43 PM   #4
Registered Member
Regular
 
sledgehammer's Avatar
 
Join Date: Nov 2007
Region: Colorado
Posts: 344
Send a message via Yahoo to sledgehammer
Re: Problem with electrical system

mine was in the engine compartment. However some alarm systems could vary. It should be somewhere on the power wire from the positive on your battery to your alarm box module.
__________________
94 v6 manual, 3.45s w/t-lock, cai, straight straight through dual exhaust, sct eliminator.
sledgehammer is offline   Reply With Quote
Old 11-29-2007, 10:56 PM   #5
Registered User
Newbie
 
Join Date: Nov 2007
Posts: 3
Re: Problem with electrical system

ok thanks. I'll look for it and let you know if it works.
kitslik is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem - 2005 2005Aaron 2005-2010 Mustang GT 5 07-27-2009 08:28 AM
electrical problem with my 65 Mustang convertible joeyemma Classic Mustangs 3 04-27-2009 10:42 PM
electrical help! please! trickflow211 1979-1995 Mustang GT 0 07-31-2008 01:25 AM
electrical problem? dave1170 1979-1995 Mustang GT 1 03-11-2008 01:51 PM
Computer system driver problem Rellik The Bar 10 02-18-2004 06:29 PM

» Like Us On Facebook



06:35 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.