Speedo going out? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-02-2012, 04:01 PM   #1
Registered Member
Regular
 
PonyBoyV6's Avatar
 
Join Date: Aug 2011
Location: Chicago Area
Region: Illinois
Posts: 1,079
Speedo going out?

Maybe i'm jumping the gun too soon, but it seems to me that my speedometer is acting a little weird. When i let off the gas, it seems to take a few seconds to start reducing in speed, just kinda hangs there for probably 10 seconds at least. I honestly don't think it was doing that before. If i let off the gas before, it'd start to reduce speed pretty consistently. Anyone ever have a problem with the speedometer in these cars? Or experience something like this? 2000 v6 by the way.
PonyBoyV6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:02 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.