Radio stopped working - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-11-2012, 12:36 PM   #1
Registered Member
Regular
 
twotone01's Avatar
 
Join Date: May 2012
Region: California
Posts: 420
Radio stopped working

Well I changed my oil this morning got in started it and everything went fine. Now I had to go to the store I got in the car did a gauge sweep then no radio. Has this happened to any of you? I disconnected the battery to see it it helped but nothing still
twotone01 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-11-2012, 12:40 PM   #2
Registered Member
Regular
 
Ghostedmind's Avatar
 
Join Date: Aug 2011
Location: Huntsville
Region: Alabama
Posts: 918
Send a message via Skype™ to Ghostedmind
Re: Radio stopped working

sounds like maybe a short. Do you have an aftermarket radio? and/or does it have a fuse behind it that maybe blew. that would be what i'd check first is fuses and relays.
__________________
Redfire '04 V6 - K&N CAI, Divorced duals, Bama Tune, EGR Delete, Gauge cluster LED overhaul.

LCMC Member
Ghostedmind is offline   Reply With Quote
Old 05-11-2012, 02:30 PM   #3
Registered Member
Regular
 
twotone01's Avatar
 
Join Date: May 2012
Region: California
Posts: 420
Its all stock still
Where is the fuse for the radio?
twotone01 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-11-2012, 05:08 PM   #4
Registered Member
Regular
 
Ghostedmind's Avatar
 
Join Date: Aug 2011
Location: Huntsville
Region: Alabama
Posts: 918
Send a message via Skype™ to Ghostedmind
Re: Radio stopped working

under the hood i believe....but i also dont think its just for the radio
__________________
Redfire '04 V6 - K&N CAI, Divorced duals, Bama Tune, EGR Delete, Gauge cluster LED overhaul.

LCMC Member
Ghostedmind is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:21 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.