Help! Mustang Problems! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-21-2012, 11:36 PM   #1
Registered Member
Regular
 
xhgwx's Avatar
 
Join Date: Oct 2011
Region: Oklahoma
Posts: 2,215
Help! Mustang Problems!

This just started tonight, I was driving home and pulled in the drive way and right before I turned the car off the whole car "flashed" meaning the lights and everything that had power went off then back on for a split second.
A few hours later the car did it again while I was driving, engine kept running but it flashed again.
Does anyone have any idea what this could be?
No warning lights in the dash or anything and it's starting to freak me out. Thanks for any replies!
xhgwx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-22-2012, 12:08 AM   #2
Registered Member
Regular
 
Las0mbra's Avatar
 
Join Date: Jan 2011
Region: Oklahoma
Posts: 2,104
Same. Exact. Thing happened to me a month ago. Turned out the bolt holding the battery lead to the side of the fuse box was loose and randomly disconnected.
Las0mbra is offline   Reply With Quote
Old 05-22-2012, 12:18 AM   #3
Registered Member
Regular
 
xhgwx's Avatar
 
Join Date: Oct 2011
Region: Oklahoma
Posts: 2,215
Quote:
Originally Posted by Las0mbra
Same. Exact. Thing happened to me a month ago. Turned out the bolt holding the battery lead to the side of the fuse box was loose and randomly disconnected.
Hmm I'll check it tomorrow! Thanks
xhgwx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-23-2012, 04:40 PM   #4
Registered Member
Regular
 
Hutchstang's Avatar
 
Join Date: Feb 2012
Region: New York
Posts: 160
There's only one reason this could happen......I'm sorry, but your car has been possessed.
Hutchstang is offline   Reply With Quote
Old 05-23-2012, 04:54 PM   #5
Registered Member
Regular
 
xhgwx's Avatar
 
Join Date: Oct 2011
Region: Oklahoma
Posts: 2,215
Quote:
Originally Posted by Hutchstang
There's only one reason this could happen......I'm sorry, but your car has been possessed.
Lololol
xhgwx is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:01 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.