Guys Help!?! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-02-2012, 02:07 PM   #1
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
Guys Help!?!

Okay....Long story short i went to rinse my car yesterday and the scoop thing fell off on the hood but i continued to wash my car....i took off down the road after and it seemed okay but once i went about a mile it seemed to be getting louder n i seen a snake and stopped and put it in reverse...i ran.it over put it.back in drive went over again and put one.more time.in reverse and then i could feel like my car shaking?!? Bad like i had somethin big in my tire i thought the snakes fang somehow did somethin lol but i popped the hood and i could see the engine moving and it was idling rough and i saw water dripping from the holes in.the hoodscoop or whatever onto my engine...i reversed again n saw some sort of fluid...not sure what it was a friend told me it smelled like transmission fluid...i went home n sort of punched the gas to see whatd it do it would shift okay but there was a major lag and power loss and just drove slow home after and my service engine light began to flash at me....any help would be appreciated(:
Brandonb2012 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2012, 02:17 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

probably got water on the ignition coil...get the code checked...it'll probably be multiple cylinder misfire....could also be the plugs or wires, but in most cases coil pack....let us know what the code is and we can help more
1slosix is offline   Reply With Quote
Old 07-02-2012, 02:24 PM   #3
Registered Member
Regular
 
Horseplay's Avatar
 
Join Date: Oct 2011
Location: San Antonio, TX
Region: Texas
Posts: 4,265
yea it sounds like its ur coils. that or u wet ur spark plug wires.
__________________

Low2v
Horseplay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2012, 03:01 PM   #4
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
Thanks guys...guess that means i gotta drive it over to NAPA....i was scared to drive it...but it was already throwing a code that someone told me was from an o2 sensor prolly but its been on since i.bought the car 3 months.ago

---------- Post added at 02:01 PM ---------- Previous post was at 01:52 PM ----------

Damn just find out we dont have one in town....closest place is Autozone and thats 30miles away...do yall think it safe to drive it there?
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 03:02 PM   #5
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

Which o2? If its from a sensor then it can also play a role in this...if its the monitors (downstreams) then it just an emissions code telling the car the cats arent working right
1slosix is offline   Reply With Quote
Old 07-02-2012, 04:16 PM   #6
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
i really dont know it was just a guess from him n it never affected the car so never fixed it....checked my.oil its about a quart low and pretty dark..needs to be changed but i dont think that would affect it like.that? i was going to drive it to a mechanic here but i feel like engines going to fall.through its shakin so rough like a mounts broken? but i dont.think.it would show up on the.computer?
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 04:26 PM   #7
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

Just go buy a new coil and plugs...takes 20 minutes to swap it all in the parking lot of the store....heck if you dont have tools most will let you use theirs...honestly never go to a mechanic if you can fix it on your own..your wallet will thank you
1slosix is offline   Reply With Quote
Old 07-02-2012, 04:39 PM   #8
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
You think thatll.fix it?
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 04:42 PM   #9
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

98% sure all you did was get them wet...
1slosix is offline   Reply With Quote
Old 07-02-2012, 05:11 PM   #10
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
Just got price check Bosche Platinum Plugs 3.89 a piece and 76.89 for coil tax and all would be $108.50....
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 05:13 PM   #11
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

forget bosche..they are junk...get some autolites and have a good day
1slosix is offline   Reply With Quote
Old 07-02-2012, 05:21 PM   #12
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
i think thats all they might carry here....little town...how much do those.run?
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 05:24 PM   #13
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

if you have an auto parts they have autolite..they are a national brand...heck even walmart carries autolite plugs

as for price coppers will run you about $2.10 a plug (which is what i run) or you can run the factory platinums for about $1 more a plug
1slosix is offline   Reply With Quote
Old 07-02-2012, 05:56 PM   #14
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
thanks and would the coil be where the wires plug in to?
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 06:01 PM   #15
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

Yea the rectangle that all six wires go into is the coil
1slosix is offline   Reply With Quote
Old 07-02-2012, 06:04 PM   #16
Registered Member
Regular
 
Havoc's Avatar
 
Join Date: May 2012
Region: California
Posts: 393
Quote:
Originally Posted by 1slosix
Yea the rectangle that all six wires go into is the coil
Lol
__________________


Hav·oc/ˈhavək/
Noun: Widespread destruction.
Verb: Lay waste to; devastate.

2000- V6 First Stang
Havoc is offline   Reply With Quote
Old 07-02-2012, 06:13 PM   #17
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

Quote:
Originally Posted by Havoc View Post
Lol
Lol i tried to make it easy for him
1slosix is offline   Reply With Quote
Old 07-02-2012, 06:21 PM   #18
Registered Member
Regular
 
Havoc's Avatar
 
Join Date: May 2012
Region: California
Posts: 393
It's understandable some people have to start somewhere
__________________


Hav·oc/ˈhavək/
Noun: Widespread destruction.
Verb: Lay waste to; devastate.

2000- V6 First Stang
Havoc is offline   Reply With Quote
Old 07-02-2012, 06:23 PM   #19
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
haha sorry never replaced one but i.thought so.cuz i wanted to.buy the screamen demon one at one time well me n my dad just pulled a plug out and they were bosche platinums to....u think they been replaced before? and it had some sorta liquid....a friend of mine said his did same n he just took spark plugs out n blew air in it and drove it to work n it cleared up
Brandonb2012 is offline   Reply With Quote
Old 07-02-2012, 06:29 PM   #20
Registered Member
Regular
 
07regency's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 111
Yea you just had a wet plug. Happens to me.almost everytime we get a good rain. I just blew out the water dried it up and worked perfect after.
07regency is offline   Reply With Quote
Old 07-02-2012, 07:10 PM   #21
Registered Member
Regular
 
Fourloko530's Avatar
 
Join Date: Feb 2012
Region: California
Posts: 567
Thats why im affraid to wash my engine
Fourloko530 is offline   Reply With Quote
Old 07-02-2012, 07:15 PM   #22
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
Okay i.found.the problem! its my coil...i left engine.runnin and pulled the wires...everytime i pulled them itd idle worse but one wire didnt do anything and it happened to be the wire that had the wet sparkplug...my dad said that its wet because its still shooting gas to it but its not burning it because that part of the coil is out....

---------- Post added at 06:15 PM ---------- Previous post was at 06:15 PM ----------

and yeah why do the carwashes even say u can wash ur engine lol
Brandonb2012 is offline   Reply With Quote
Old 07-03-2012, 02:09 PM   #23
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Guys Help!?!

did you say you had a screamin demon coil pack? if so that's a junky ignition coil...swap for stock for an instantly smoother ride
1slosix is offline   Reply With Quote
Old 07-03-2012, 02:18 PM   #24
Registered Member
Regular
 
Havoc's Avatar
 
Join Date: May 2012
Region: California
Posts: 393
Re: Guys Help!?!

Quote:
Originally Posted by 1slosix View Post
did you say you had a screamin demon coil pack? if so that's a junky ignition coil...swap for stock for an instantly smoother ride
I understand the stock ones in our cars are the best even when add HP, but ours for some reason have a tendency of going out. IMO I like MSD they are the same price as a new OEM. So I say just stick with the OEM over the screamin demon.
__________________


Hav·oc/ˈhavək/
Noun: Widespread destruction.
Verb: Lay waste to; devastate.

2000- V6 First Stang
Havoc is offline   Reply With Quote
Old 07-03-2012, 02:21 PM   #25
Registered Member
Regular
 
Horseplay's Avatar
 
Join Date: Oct 2011
Location: San Antonio, TX
Region: Texas
Posts: 4,265
i use ford motorcraft for my coils plugs and wires
__________________

Low2v
Horseplay is offline   Reply With Quote
Old 07-03-2012, 03:14 PM   #26
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
No no i was.going to buy one.but thanks for.the info....im waiting on my dad to get outta work...hes gunna go pick me up a coil...the one here in town only has 90 day warranty but they got 1 year warranty for 65 and lifetime for 76 at Autozone 30 miles away....too far to walk lol
Brandonb2012 is offline   Reply With Quote
Old 07-03-2012, 06:22 PM   #27
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
thanks for help guys its back running smooth(:
Brandonb2012 is offline   Reply With Quote
Old 07-03-2012, 06:24 PM   #28
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
I berly noticed this lol....any idea what it is for?

Click image for larger version

Name:	ForumRunner_20120703_182407.png
Views:	105
Size:	319.5 KB
ID:	57449
Brandonb2012 is offline   Reply With Quote
Old 07-03-2012, 07:15 PM   #29
Registered Member
Regular
 
mustangg2000's Avatar
 
Join Date: Nov 2011
Region: Arkansas
Posts: 654
It's a ground wire
mustangg2000 is offline   Reply With Quote
Old 07-03-2012, 07:37 PM   #30
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
to what tho? haha
Brandonb2012 is offline   Reply With Quote
Old 07-03-2012, 07:41 PM   #31
Registered Member
Regular
 
mustangg2000's Avatar
 
Join Date: Nov 2011
Region: Arkansas
Posts: 654
Hood light I do believe
mustangg2000 is offline   Reply With Quote
Old 07-03-2012, 07:44 PM   #32
Registered Member
Regular
 
Havoc's Avatar
 
Join Date: May 2012
Region: California
Posts: 393
To the extra 2 cylinders that your car is hiding from you hahahahaa just kidding have no clue but I would follow the wire an see where it leads, that's where I would start
__________________


Hav·oc/ˈhavək/
Noun: Widespread destruction.
Verb: Lay waste to; devastate.

2000- V6 First Stang
Havoc is offline   Reply With Quote
Old 07-03-2012, 08:12 PM   #33
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
its hard to follow lol n pshh i wish it was a v8 ha
Brandonb2012 is offline   Reply With Quote
Old 07-05-2012, 12:14 AM   #34
Registered Member
Regular
 
Blackbeauty95's Avatar
 
Join Date: May 2012
Region: Ohio
Posts: 133
To bad you dont live close i have a v8 im looking to trade for the new edge body style and i dont car if it has a 6 or 8 in it i just love the looks
Blackbeauty95 is offline   Reply With Quote
Old 07-05-2012, 04:35 AM   #35
Registered Member
Regular
 
Brandonb2012's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 295
sounds good but nahh i lovee my baby ha even tho she makes me mad sometimess...just gotta fix.her.up a little shes been through hell
Brandonb2012 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:58 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.