Third Brake Light - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Closed Thread
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-18-2012, 05:52 PM   #1
Registered User
Newbie
 
nick.go90's Avatar
 
Join Date: Jul 2012
Region: Kentucky
Posts: 19
Third Brake Light

I just replaced my third brake light with a smoked Led one. But for some reason it doesn't want to come on. Any ideas what could be going on?
nick.go90 is offline  
Sponsored Links
Advertisement
 
Old 07-18-2012, 06:01 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Third Brake Light

Is it a plug and play one or one you splice in?
1slosix is offline  
Old 07-18-2012, 06:21 PM   #3
Registered User
Newbie
 
nick.go90's Avatar
 
Join Date: Jul 2012
Region: Kentucky
Posts: 19
Plug and play
nick.go90 is offline  
Sponsored Links
Advertisement
 
Old 07-18-2012, 06:41 PM   #4
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Third Brake Light

Take a test light to it...
1slosix is offline  
Old 07-18-2012, 07:11 PM   #5
Registered User
Newbie
 
nick.go90's Avatar
 
Join Date: Jul 2012
Region: Kentucky
Posts: 19
Well i guess i should have gone out there before i posted this. Turns out the connectors from the led light didnt allow enough wire through to connect to my wire harness. I ended up having to push more wire through and also went back through to double check positive and negatives. I thought it may have been my wire harness in the first place because my original third brake didnt work. But all is well now!
nick.go90 is offline  
Old 07-18-2012, 07:35 PM   #6
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Third Brake Light

Good work lol...glad it wasnt a bum led strip
1slosix is offline  
Old 07-19-2012, 12:22 AM   #7
Registered Member
Regular
 
kickerofdoom's Avatar
 
Join Date: Mar 2011
Region: Maryland
Posts: 1,868
I had to cut the wires and just tie them together. Make sure they stay together
kickerofdoom is offline  
Old 07-19-2012, 01:23 AM   #8
Registered User
Newbie
 
nick.go90's Avatar
 
Join Date: Jul 2012
Region: Kentucky
Posts: 19
Yeah, now since I had trouble getting them to work im going to be paranoid about one section of the leds going out so I will be checking daily now lol absolutely drives me nuts
nick.go90 is offline  
Closed Thread

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:21 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.