Engine not revving? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-21-2012, 08:44 PM   #1
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
Engine not revving?

Normally when I have the accelerator pedal floored, (in drive) it will rev up very quickly and will max out at 5200 rpm but now moves very slowly and peaks at about 4200, and I've noticed a MAJOR power loss, what could be wrong?
Supersnake04 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2012, 09:40 PM   #2
Registered Member
Regular
 
Dgerow12's Avatar
 
Join Date: Aug 2011
Region: New York
Posts: 502
Sound like a major vacuum leak to me. Same thing happened on my older car. Sound like you have a rev limiter right?
Dgerow12 is offline   Reply With Quote
Old 07-21-2012, 10:21 PM   #3
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
Yeah I have one

---------- Post added at 11:21 PM ---------- Previous post was at 11:17 PM ----------

Well I don't think so if you force it you can make it go over 53-5400 but that's in the redline...
Supersnake04 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2012, 10:58 PM   #4
Registered Member
Regular
 
Dgerow12's Avatar
 
Join Date: Aug 2011
Region: New York
Posts: 502
No I mean when you rev it up and it stops does it jump like a rev limiter or just stop like its misfiring. A rev limiter has a more noticeable jump to it when it stops it
Dgerow12 is offline   Reply With Quote
Old 07-21-2012, 11:00 PM   #5
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
It just stops
Supersnake04 is offline   Reply With Quote
Old 07-21-2012, 11:03 PM   #6
Registered Member
Regular
 
Dgerow12's Avatar
 
Join Date: Aug 2011
Region: New York
Posts: 502
Sounds like a vacuum leak
Dgerow12 is offline   Reply With Quote
Old 07-22-2012, 01:21 AM   #7
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
Re: Engine not revving?

when you're just taking off easily does the car hesitate a lot? jumpy as you move?
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Old 07-22-2012, 02:35 AM   #8
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
It has an easy take-off but it doesn't want to go very quickly
Supersnake04 is offline   Reply With Quote
Old 07-22-2012, 10:40 AM   #9
Registered Member
Regular
 
johnofarch14's Avatar
 
Join Date: Apr 2012
Location: Inverness
Region: Illinois
Posts: 285
Send a message via Skype™ to johnofarch14
Quote:
Originally Posted by Supersnake04
It has an easy take-off but it doesn't want to go very quickly
Most likely it's a bad spark plug or spark plug wire but could be basically anything in the ignition system. I would give it a good tune up and then see how it does.
__________________
johnofarch14 is offline   Reply With Quote
Old 07-22-2012, 11:03 PM   #10
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
Re: Engine not revving?

an old trick.. pop the hood and run the car at night in complete darkness, look for any blue "sparks" coming from plug wires that would rule out any arching between wires
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Old 07-22-2012, 11:05 PM   #11
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
Unplug the wires?
Supersnake04 is offline   Reply With Quote
Old 07-22-2012, 11:10 PM   #12
slow281
Regular
Supporter
 
sixpac's Avatar
 
Join Date: Mar 2012
Location: Cedar Rapids
Region: Nebraska
Posts: 3,162
Quote:
Originally Posted by Supersnake04
Unplug the wires?
No just watch them
__________________
Need more Horsepower? Add a sticker. Contact me for vinyl stickers pre-made and custom!
Stick on Horsepower <- Click Here and like my Page!
2001 GT - True Blue
2003 V6 - Zinc Yellow
1990 LX 2.3 - project
sixpac is offline   Reply With Quote
Old 07-22-2012, 11:17 PM   #13
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
Re: Engine not revving?

LOL yes keep them on the car, or there will be plenty of sparks flying
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Old 07-22-2012, 11:19 PM   #14
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
Oh, forgot about that... Please note, I'm posting at 12:18 am
Supersnake04 is offline   Reply With Quote
Old 07-22-2012, 11:22 PM   #15
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
Re: Engine not revving?

i'm a night owl... time means nothing to me! haha
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Old 07-22-2012, 11:25 PM   #16
slow281
Regular
Supporter
 
sixpac's Avatar
 
Join Date: Mar 2012
Location: Cedar Rapids
Region: Nebraska
Posts: 3,162
Quote:
Originally Posted by davidcseifert
i'm a night owl... time means nothing to me! haha
+1
__________________
Need more Horsepower? Add a sticker. Contact me for vinyl stickers pre-made and custom!
Stick on Horsepower <- Click Here and like my Page!
2001 GT - True Blue
2003 V6 - Zinc Yellow
1990 LX 2.3 - project
sixpac is offline   Reply With Quote
Old 07-22-2012, 11:28 PM   #17
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
I'm normally wide awake at night.
Supersnake04 is offline   Reply With Quote
Old 09-29-2012, 09:23 PM   #18
Road Trip!
 
Join Date: Jul 2012
Region: South Carolina
Posts: 282
Fixed a while ago but what the hell, found out that the front left catalytic converter disintegrated, and clogged up converter 2 eventually to the point that the left cylinder bank was unable to release exhaust making it completely irrelevant, so it was almost like I was running off 3 cylinders. So I got a new system from an 02 donor Stang. But all in all there was no engine damage so I'm happy.
Supersnake04 is offline   Reply With Quote
Old 09-29-2012, 11:03 PM   #19
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
damn i hate cats... thats why i no longer have any
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Old 09-30-2012, 05:37 AM   #20
Registered Member
Regular
 
ForsakenProto's Avatar
 
Join Date: Jun 2011
Region: North Carolina
Posts: 1,143
Quote:
Originally Posted by davidcseifert
damn i hate cats... thats why i no longer have any
Amen, my front two are gone, the other 2 go tonight
ForsakenProto is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:54 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.