Turn Signal Frustration!!! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-05-2012, 09:44 AM   #1
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Turn Signal Frustration!!!

Hey guys,

I am at my wits end with trying to figure out why my Turn Signals will not work on my 1994 Mustang V6. I have done a few things that were recommended and none of them have panned out yet.
  1. I replaced the Multi-Function Switch
  2. I replaced the Turn Signal Relay

None of those things have given me anything. The thing that is confusing is that my Hazard Lights work. Since those work it only makes sense that my Turn Signals would work as well. Any ideas in regards to this before I jump off of the roof...
devanslive is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2012, 10:15 AM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Turn Signal Frustration!!!

there are two flashers...one for the turn signals and one for the hazards...one can work and not the other. spend the $6 to replace the turn signal flasher and see how that goes
1slosix is offline   Reply With Quote
Old 09-05-2012, 10:39 AM   #3
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by 1slosix View Post
there are two flashers...one for the turn signals and one for the hazards...one can work and not the other. spend the $6 to replace the turn signal flasher and see how that goes
Okay, now I am confused. I replaced the Turn Signal Relay and that is the little plug like piece right behind the fuses by your left leg in the car. Is that not what you are referring to? Thanks

---------- Post added at 11:39 AM ---------- Previous post was at 11:34 AM ----------

Quote:
Originally Posted by devanslive View Post
Okay, now I am confused. I replaced the Turn Signal Relay and that is the little plug like piece right behind the fuses by your left leg in the car. Is that not what you are referring to? Thanks
Is the one you are referring to located somewhere else? I thought the Turn Signal Flasher/Relay was located in the car under the dash behind the fuse block.
devanslive is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2012, 10:40 AM   #4
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Turn Signal Frustration!!!

the flasher is cylinder looking plug in....usually a two prong
1slosix is offline   Reply With Quote
Old 09-05-2012, 10:42 AM   #5
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by 1slosix View Post
the flasher is cylinder looking plug in....usually a two prong
That looks to be the same thing I replaced right behind the fuse block under the dash. Where is the location of the one you are referring to?
devanslive is offline   Reply With Quote
Old 09-05-2012, 10:44 AM   #6
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by devanslive View Post
That looks to be the same thing I replaced right behind the fuse block under the dash. Where is the location of the one you are referring to?
in that location...never swapped one on my mustang. although most vehicles have 2 as i said before. check on google
1slosix is offline   Reply With Quote
Old 09-05-2012, 10:47 AM   #7
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by 1slosix View Post
in that location...never swapped one on my mustang. although most vehicles have 2 as i said before. check on google
Okay, I will look for the other one.
devanslive is offline   Reply With Quote
Old 09-12-2012, 08:44 PM   #8
Registered User
Newbie
 
Velarde410's Avatar
 
Join Date: Aug 2012
Region: Maryland
Posts: 2
The round relay fuse behind the fuse box is your hazard relay. There is another under your dash close to your steering colum. This is your relay for your turn signals. I have the same problem with my 87 gt. I replaced both flasher relays and now im going to try replacing the multi function switch. Hope it works.
Velarde410 is offline   Reply With Quote
Old 09-12-2012, 09:41 PM   #9
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 525
Re: Turn Signal Frustration!!!

when you put it in the turn position,,does all the lights light up but dont blink,,if so it def sounds like the turn signal flasher like the other guys were saying,,now if none of the lights come on then it could be something else,,Now im not sure about your year but there is regular flasher relay and a electronic flasher relay,,so make sure its the right one
__________________
mymustang is offline   Reply With Quote
Old 09-12-2012, 10:14 PM   #10
Registered User
Newbie
 
Velarde410's Avatar
 
Join Date: Aug 2012
Region: Maryland
Posts: 2
Yea my hazards blink but not on the dash and when I turn on my turn signals nothing on the dash or the lights. I hope a new multi function switch will work.
Velarde410 is offline   Reply With Quote
Old 09-12-2012, 10:22 PM   #11
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Quote:
Originally Posted by mymustang
when you put it in the turn position,,does all the lights light up but dont blink,,if so it def sounds like the turn signal flasher like the other guys were saying,,now if none of the lights come on then it could be something else,,Now im not sure about your year but there is regular flasher relay and a electronic flasher relay,,so make sure its the right one
That is weird because I see the relay behind the fuse box, but cannot find the other relay that everyone is referring to.
devanslive is offline   Reply With Quote
Old 09-13-2012, 01:11 PM   #12
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: Turn Signal Frustration!!!

You replaced the only two components, it would point me to an electrical problem. Fuses, loose wire/broken wire. Then the headlight switch wire harness.
Mustang Headlight Switch Repair Harness (94-04 All) 1120 - Free Shipping!
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 09-13-2012, 01:24 PM   #13
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by robb15033 View Post
You replaced the only two components, it would point me to an electrical problem. Fuses, loose wire/broken wire. Then the headlight switch wire harness.
Mustang Headlight Switch Repair Harness (94-04 All) 1120 - Free Shipping!
Yeah, I am going to replace the headlight switch and harness this weekend. That has an impact on the Turn Signals as well?
devanslive is offline   Reply With Quote
Old 09-14-2012, 12:06 PM   #14
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: Turn Signal Frustration!!!

Read this, maybe reach out and compare issues.
My car is driving me crazy!!!
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 09-14-2012, 12:08 PM   #15
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 139
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by robb15033 View Post
Read this, maybe reach out and compare issues.
My car is driving me crazy!!!
There was no link
devanslive is offline   Reply With Quote
Old 09-15-2012, 01:30 PM   #16
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: Turn Signal Frustration!!!

Quote:
Originally Posted by devanslive View Post
There was no link
Yeah, it works for me. Click the blue words. My car is driving me crazy!!!
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 09-15-2012, 01:33 PM   #17
Moderator Emeritus
Regular
 
deadsp0t's Avatar
 
Join Date: Aug 2011
Location: MidWorld
Region: Other
Posts: 4,786
Works for me as well!
__________________
That's unimpressive
deadsp0t is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:23 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.