problem with speedometer lights and radio - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-24-2012, 01:54 PM   #1
Registered User
Newbie
 
Join Date: Sep 2012
Region: Arkansas
Posts: 1
problem with speedometer lights and radio

So i have a 2000 model v6 convertable with a aftermarket stereo and i was driving down the road and i see sparks flash under the stereo... Sterio stops working and also the speedometer lights... Fuse was blown but i replaced it and it still wont work. What do i freakin do?
nateelliott7 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2012, 12:05 AM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
your aftermarket radio probably grounded out and shorted out a wire somewhere...pull the radio out and check the back of it...usually there is a fuse back there as well. also loook at all the wiring for burnt coverings. then pull the cluster and check the wiring to it.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:09 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.