1996 Electrical Issues - Various ??? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-20-2012, 10:31 PM   #1
Registered User
Newbie
 
Join Date: Oct 2012
Region: Texas
Posts: 3
Question 1996 Electrical Issues - Various ???

Helllo all, I just bought a 1996 fixer upper for my daughter. Trying to go through it and list all the known issues for repair.

Main electrical issues:

RESOLVED 1. When turning key, opposite of starting, of which I'd usually call it accessory only mode, nothing powers up at all. Update: Cleaned bulkhead conections at the drivers kickpanel, and of course it could have been that missing fuse as well.

RESOLVED 2. ODBII port apparently is not powering up my tester, as it says it must be powered by the vehicle. Therefore it's only running on it's internal battery in order to display the error mentioned. Update: Radio fuse was completely missing, checked all existing fuses, never dreamed a fuse would be missing.

RESOLVED 3. Radio does not work, no power. Update: Radio fuse was completely missing, checked all existing fuses, never dreamed a fuse would be missing.

RESOLVED 4. Front seat will not move in any direction, I assume no power as well. Note: The very first time I tried to move the seat, it moved for a couple of seconds and then nothing. Prior to that short movement, all of the other electrical issues were already noted as being an issue. Update: Found fusebox under the hood, fuse for seats blown.

5. Driver's window will not operate, no noise, assuming no power, yet the passenger unit is fine.

6. Electronic doorlock's do not work. Now when I press the locking button, I hear a motor in the drivers door run, but no lock movement.

RESOLVED 7. Electronic mirror adjustments do not work, either side. Update: Could have been the bulkhead connector cleaning or the missing fuse.

8. Voltmeter in instrument panel does not work.

Thanks in advance for any help one might be able to throw at me.
TexomaEV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-2012, 10:51 PM   #2
Registered Member
Regular
 
V6 stang's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 2,252
Hmm. To start simple check every single power hook up to see if its plugged in and not corroded to the point of not working.

Number 1 could maybe be the chip bad in your key? My friends chip came loose in his and it wouldn't turn, some will turn but nothin happens.. Some turn the motor over but never actually cranks up..
__________________
"Hp sells cars, Tq wins races" - Carroll Shelby... RIP
2012 Mustang GT Convertible
Roush Exhaust

2003 Mustang GT (Sold)
1999 35th Anniversary V6(SOLD)
V6 stang is offline   Reply With Quote
Old 11-10-2012, 06:41 PM   #3
Registered User
Newbie
 
Join Date: Oct 2012
Region: Texas
Posts: 3
Resolved #5: Window operation - Electrical connector inside the door to the window motor disconnected.

Reslolved #6: Door Locking issue, had to replace electric lock actuators.

Resolved #8: Voltmeter and Oil Gauge were fixed by removing the instrument cluster, and cleaning the copper flex circuitboard with WD40.
TexomaEV is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:57 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.