injectors not opening im new please help! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-23-2012, 08:05 PM   #1
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
injectors not opening im new please help!

96 3.8 base... My injectors are not functioning at all. I'm getting fuel pressure all the way up to the rail, but the injectors are not allowing fuel through. Please someone give advice I'm new to this forum it's my last resort my car has been out of commission for about a month, thank you.
mikedeck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2012, 01:07 AM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
are they just clogged and sputtering or no fuel at all? you can either A. suck Seafoam straight into that upper with the vaccum line off the brake booster (not too much at once) B. pull the injectors put them in a bowl and fill the bowl with seafoam..let them sit overnight
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 10-24-2012, 01:39 AM   #3
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,862
Here's a link on how to test your injectors...
How to Test the Fuel Injectors
(Ford 3.0L, 3.8L)


Here's a link on how to clean your injectors...
Home Made Injector Cleaner
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2012, 09:42 AM   #4
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
I guess i should have been more specific, i already tried replacing the injectors so i know its not the injectors themselves. it has to be something electronic controling the injectors. I've checked all the fuses. as far as i know there is no relay specifically for the injectors on the 96.

---------- Post added at 09:42 AM ---------- Previous post was at 09:40 AM ----------

By the way thank you for your time guys.
mikedeck is offline   Reply With Quote
Old 10-24-2012, 12:49 PM   #5
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,862
Quote:
Originally Posted by mikedeck View Post
I guess i should have been more specific, i already tried replacing the injectors so i know its not the injectors themselves. it has to be something electronic controling the injectors. I've checked all the fuses. as far as i know there is no relay specifically for the injectors on the 96.

---------- Post added at 09:42 AM ---------- Previous post was at 09:40 AM ----------

By the way thank you for your time guys.
So, you have pressure at the rails. You have new injectors, but they are not operating. And you are getting a trouble code? I'm just curious if there is something else that is malfunctioning that is causing this to happen. We don't want to replace something that is working fine. Have you performed any tests that would confirm you are getting power to the injectors?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 10-24-2012, 06:27 PM   #6
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
Just checked, no power getting to injectors, damnn itttt
mikedeck is offline   Reply With Quote
Old 10-24-2012, 07:40 PM   #7
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,862
Quote:
Originally Posted by mikedeck View Post
Just checked, no power getting to injectors, damnn itttt
Sorry, that sucks. Did you test with a noid light? The light will flash when voltage is present. If your not getting voltage, maybe your wire harness is damaged somewhere. Could be something wrong with the PCM. Maybe the crank sensor or cam sensor are malfunctioning and making it so the PCM is not calling for fuel from the injectors.
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 10-24-2012, 08:18 PM   #8
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
im having trouble locating the crankshaft sensor, any clue where its at? Thanks again for the help.
mikedeck is offline   Reply With Quote
Old 10-24-2012, 08:39 PM   #9
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,862
Quote:
Originally Posted by mikedeck View Post
im having trouble locating the crankshaft sensor, any clue where its at? Thanks again for the help.
Here's a pic from my Chiltons. Hope that helps
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 10-26-2012, 05:48 PM   #10
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
Tested crank shaft sensor and its workin perfectly
mikedeck is offline   Reply With Quote
Old 10-27-2012, 03:09 PM   #11
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
Thank you for your time everyone, i took it to my mechanic today I just don't have the time to chase electrical problems right now wish me luck though haha
mikedeck is offline   Reply With Quote
Old 10-27-2012, 05:12 PM   #12
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,862
Quote:
Originally Posted by mikedeck View Post
Thank you for your time everyone, i took it to my mechanic today I just don't have the time to chase electrical problems right now wish me luck though haha
Cool, totally understand that. Gook luck. I hope it's something simple where we can all go "ah, I shoulda thought of that".
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 10-29-2012, 12:18 PM   #13
Registered User
Newbie
 
Join Date: Oct 2012
Region: California
Posts: 7
Yeaa ill defiantly let u know what it was thanks again
mikedeck is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CAI and 31 LB injectors southernstang00 Mustang Parts for Sale and Wanted 10 10-27-2012 02:30 PM
Fuel injectors? WhiteCobra94 1979-1995 Mustang GT 12 01-05-2012 08:03 PM
injectors Robbie94gt 1979-1995 Mustang GT 18 11-21-2011 08:30 PM
Fuel injectors ?? stangstar92 1996-2004 Mustang GT 3 10-05-2011 05:59 PM
60 lb injectors question? CZYFAST 2011-2014 Mustang GT 27 07-19-2011 03:56 PM

» Like Us On Facebook



07:57 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.