No power to both lighters - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-29-2012, 12:29 PM   #1
Registered Member
Regular
 
JB_MUSTANG_V6's Avatar
 
Join Date: Aug 2012
Region: Pennsylvania
Posts: 110
No power to both lighters

I am getting a satellite radio today but my lighters do not work so I cannot plug the power source from the radio in. Is it a fuse or what?
JB_MUSTANG_V6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-29-2012, 10:47 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
yes there is a fuse
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 11-02-2012, 04:27 PM   #3
Registered Member
Regular
 
joey18's Avatar
 
Join Date: Jul 2012
Location: Corona
Region: California
Posts: 876
Mine does the same thing... they worked when i bought the car but suddenly stopped and all the fuses are fine.
__________________
joey18 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-03-2012, 03:34 AM   #4
Registered Member
Regular
 
JB_MUSTANG_V6's Avatar
 
Join Date: Aug 2012
Region: Pennsylvania
Posts: 110
Quote:
Originally Posted by joey18
Mine does the same thing... they worked when i bought the car but suddenly stopped and all the fuses are fine.
Yea I think they worked when I got mine but now the one near the shifter doesn't work but the one where the ash tray is does work. So weird.
JB_MUSTANG_V6 is offline   Reply With Quote
Old 11-03-2012, 03:40 AM   #5
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
There's a couple of things to check. If your fuses are fine, there could be a fault in the connect to the 12V socket (lighter). Pull it out and check the connection. Also, the socket itself could be worn out. Swap your working socket with the defective one. See if that makes a difference.
primer2tone is offline   Reply With Quote
Old 11-04-2012, 07:31 AM   #6
Registered Member
Regular
 
Crowned1's Avatar
 
Join Date: Oct 2012
Region: Texas
Posts: 748
Quote:
Originally Posted by JB_MUSTANG_V6
I am getting a satellite radio today but my lighters do not work so I cannot plug the power source from the radio in. Is it a fuse or what?
it is most likely a fuse. the size for the one near the gear shifter is 20 amps and the number for it is 1 on your fuse box. the other one im not to sure about.
Crowned1 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:21 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.