CAI ! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-18-2013, 02:11 PM   #1
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
CAI !

Has anyone else had a problem after installing it? Like the car turning off by itself sometimes? I put it on then opened the good rev'd it and then it turned off.. Or sometimes it'll just almost turn off then bring itself back up
Xaperez100 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2013, 02:18 PM   #2
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
clean your MAF?
If you over oiled the filter then put the MAF directly behind it maybe it would do it>
Billymich is offline   Reply With Quote
Old 02-18-2013, 02:26 PM   #3
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by Billymich View Post
clean your MAF?
If you over oiled the filter then put the MAF directly behind it maybe it would do it>
Wait oiled the filter?? all I did was install it and everything I never oiled anything.-.?
Xaperez100 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2013, 05:28 PM   #4
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
No, you oil the filter when you clean it. Are all your rubber couplings tight? Is there any holes in the CAI? Like the temp. Sensor hole? Was there anything blocking the inside of the pipes when you installed it?
sam62893 is offline   Reply With Quote
Old 02-18-2013, 07:17 PM   #5
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by sam62893 View Post
No, you oil the filter when you clean it. Are all your rubber couplings tight? Is there any holes in the CAI? Like the temp. Sensor hole? Was there anything blocking the inside of the pipes when you installed it?
Oh okay the sensor when I put it in I had a hard time hard to make the hole a little bigger so that's probably it. Ill have to cover it with some silicone
Xaperez100 is offline   Reply With Quote
Old 02-18-2013, 08:05 PM   #6
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
check your maf..it doesn't take much to damage it
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 02-18-2013, 08:24 PM   #7
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by 1slosix View Post
check your maf..it doesn't take much to damage it
Yeah I know I had placed it on my shelf carefully when I took it off. Made sure not to shake it around or drop it.

---------- Post added at 08:24 PM ---------- Previous post was at 08:23 PM ----------

Quote:
Originally Posted by Xaperez100 View Post

Yeah I know I had placed it on my shelf carefully when I took it off. Made sure not to shake it around or drop it.
But ill check
Xaperez100 is offline   Reply With Quote
Old 02-18-2013, 08:24 PM   #8
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
in my f150 i broke mine when i installed the CAI back on the truck lol...that was a $90 life lesson
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 02-18-2013, 08:30 PM   #9
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by 1slosix View Post
in my f150 i broke mine when i installed the CAI back on the truck lol...that was a $90 life lesson
Lol yeah I bet I mean I'm pretty sure it's just the hole where I installed the sensor
Xaperez100 is offline   Reply With Quote
Old 02-18-2013, 10:46 PM   #10
Registered Member
Regular
 
Dbr4life's Avatar
 
Join Date: Feb 2013
Location: Hillsboro
Region: Missouri
Posts: 24
I'd go with buying a variety pack of rubber grommets vs the silicone, gets old or have to replace the sensor (AIT I'm guessing ?) and it can fall in your air intake tube go bad places lol
Dbr4life is offline   Reply With Quote
Old 02-19-2013, 02:02 AM   #11
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by Dbr4life View Post
I'd go with buying a variety pack of rubber grommets vs the silicone, gets old or have to replace the sensor (AIT I'm guessing ?) and it can fall in your air intake tube go bad places lol
Lol I fixed it and I have a little fan that spins inside my intake while I'm driving so I'm sure that would cut it up if it did fall in.-. But I fixed the problem it was probably just loose I took it off and tightened everything it runs nicely:p thanks everyone!
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 06:58 AM   #12
Registered Member
Regular
 
Dbr4life's Avatar
 
Join Date: Feb 2013
Location: Hillsboro
Region: Missouri
Posts: 24
Glad to hear!! Sucks having a car down, but I wouldn't use that logic with the fan in your intake cutting it up lol
Dbr4life is offline   Reply With Quote
Old 02-19-2013, 08:22 AM   #13
Registered Member
Regular
 
Project Pony's Avatar
 
Join Date: Jan 2011
Location: Aiken
Region: South Carolina
Posts: 3,274
Fan in your intake? Like one of those scam "electric turbo chargers"?!

Please tell me that's not true.......
__________________
[SIGPIC][/SIGPIC]
Project Pony is offline   Reply With Quote
Old 02-19-2013, 09:49 AM   #14
Registered Member
Regular
 
Crowned1's Avatar
 
Join Date: Oct 2012
Region: Texas
Posts: 748
Quote:
Originally Posted by Project Pony View Post
Fan in your intake? Like one of those scam "electric turbo chargers"?!

Please tell me that's not true.......
oh lord don't let it be!!!
Crowned1 is offline   Reply With Quote
Old 02-19-2013, 10:18 AM   #15
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Lol! No not the electric turbo things it only rotates when the cars pulling in air. It just helps a little on gas
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 11:42 AM   #16
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
No it doesnt lol..its a restriction
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 02-19-2013, 11:44 AM   #17
Registered Member
Regular
 
Dbr4life's Avatar
 
Join Date: Feb 2013
Location: Hillsboro
Region: Missouri
Posts: 24
Sounds like same thing just advertised differently lol
Dbr4life is offline   Reply With Quote
Old 02-19-2013, 12:02 PM   #18
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Oh.-. Lol **** it:p looks cool:p lmao idc about power right now. I have a sixxer:p just want it to look nice:p
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 01:03 PM   #19
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
Pics of the fan? Never seen one
sam62893 is offline   Reply With Quote
Old 02-19-2013, 01:05 PM   #20
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by sam62893 View Post
Pics of the fan? Never seen one
I will when I get out of this court room-.- lol
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 02:12 PM   #21
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
lol i swear take the fan off and you'll see your mpg increase
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 02-19-2013, 03:18 PM   #22
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by 1slosix View Post
lol i swear take the fan off and you'll see your mpg increase
Alrighty:p
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 05:05 PM   #23
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by sam62893 View Post
Pics of the fan? Never seen one


Click image for larger version

Name:	image-118617018.jpg
Views:	112
Size:	455.6 KB
ID:	91832



Click image for larger version

Name:	image-1125134996.jpg
Views:	115
Size:	473.6 KB
ID:	91833


Lol I took it out like slosix said:p
And it did make a difference even in sound lol and it sucks in more air as well
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 05:15 PM   #24
Registered Member
Regular
 
Project Pony's Avatar
 
Join Date: Jan 2011
Location: Aiken
Region: South Carolina
Posts: 3,274
Yep, those are a scam.
__________________
[SIGPIC][/SIGPIC]
Project Pony is offline   Reply With Quote
Old 02-19-2013, 05:43 PM   #25
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
Wow, never seen one lol. Sell it to some ricer. Tell them it ads 50hp
sam62893 is offline   Reply With Quote
Old 02-19-2013, 05:57 PM   #26
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by sam62893 View Post
Wow, never seen one lol. Sell it to some ricer. Tell them it ads 50hp
Will do;p lol
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 06:09 PM   #27
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
So where did that thing go? Like before the throttle body or something?
sam62893 is offline   Reply With Quote
Old 02-19-2013, 06:11 PM   #28
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by sam62893 View Post
So where did that thing go? Like before the throttle body or something?
Before the MAF closer to the throttle body lol
Xaperez100 is offline   Reply With Quote
Old 02-19-2013, 06:27 PM   #29
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Quote:
Originally Posted by Xaperez100 View Post
Attachment 91832



Attachment 91833


Lol I took it out like slosix said:p
And it did make a difference even in sound lol and it sucks in more air as well
lol glad i could help.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Tags
cai

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:36 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.