Check engine light - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-21-2013, 10:15 AM   #1
Registered Member
Regular
 
Blovett55's Avatar
 
Join Date: Mar 2013
Location: Greenville
Region: Ohio
Posts: 582
Check engine light

Okay so I've been having this problem for quite some time lately, My check engine light, or for mustangs the service engine soon light came on, put a scanner on it, the code came back with a camshaft sensor, replaced it, cleared the code and after about 3 days on average, same code and light come back on, so I was wondering if anyone else gets this B/S code, or if they know what the real problem is that is throwing out a bad/wrong code
Blovett55 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2013, 12:26 PM   #2
Registered Member
Regular
 
Ghostedmind's Avatar
 
Join Date: Aug 2011
Location: Huntsville
Region: Alabama
Posts: 918
Send a message via Skype™ to Ghostedmind
Sometimes electronics will just go bad, (even if it's brand new) this time I suggest testing the Camshaft Position Sensor (CPS) according to a Haynes manual before you just replace it. because it could just need cleaning. If you clean it up and it tests good then I would look deeper than just the CPS. I would look to see if there is something causing it to go bad. Never trust the SES/CEL codes 100%, always inspect the part.
__________________
Redfire '04 V6 - K&N CAI, Divorced duals, Bama Tune, EGR Delete, Gauge cluster LED overhaul.

LCMC Member
Ghostedmind is offline   Reply With Quote
Old 04-21-2013, 01:04 PM   #3
Registered Member
Regular
 
Blovett55's Avatar
 
Join Date: Mar 2013
Location: Greenville
Region: Ohio
Posts: 582
No, when I took it off, it looked fine, but the part was only 20 so I went ahead and threw the new part on
Blovett55 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2013, 11:56 PM   #4
Registered Member
Regular
 
SpeedyG's Avatar
 
Join Date: Mar 2013
Location: Hackensack
Region: New Jersey
Posts: 402
Quote:
Originally Posted by Blovett55 View Post
No, when I took it off, it looked fine, but the part was only 20 so I went ahead and threw the new part on
I got the same code recently, mechanic told me to reset it and just keep driving it will go away. He checked it and mine was fine, could be a bogus code especially if you changed it new.
SpeedyG is offline   Reply With Quote
Old 04-22-2013, 06:52 AM   #5
Registered Member
Regular
 
Blovett55's Avatar
 
Join Date: Mar 2013
Location: Greenville
Region: Ohio
Posts: 582
So even though I put a new one in and still getting the code, just every time it comes up just clear the code, because it'll come back on in about 4 days, I mean it doesn't run wrong at all but the light just bothers me because u can't always tell something is wrong by the sound
Blovett55 is offline   Reply With Quote
Old 04-22-2013, 12:16 PM   #6
Registered Member
Regular
 
Berry_Eggo's Avatar
 
Join Date: Nov 2012
Region: Georgia
Posts: 107
Quote:
Originally Posted by Blovett55 View Post
So even though I put a new one in and still getting the code, just every time it comes up just clear the code, because it'll come back on in about 4 days, I mean it doesn't run wrong at all but the light just bothers me because u can't always tell something is wrong by the sound
Try removing your battery for 5min then place it back
Berry_Eggo is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:34 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.