problem - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-30-2013, 07:37 PM   #1
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
problem

So my grandpa has a 02 V6 with 160xxx miles. Its really gettin sluggish taking off and while its sitting at idle its like the engine is rumbling or rocking back and forth. Last thing is that when I got done taking it for a ride it smelled really funny. All gauges read fine. It said service engine soon. So I figure maybe just a tune up and such. If so what do I need and what should I do. Thanks
V6in is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-30-2013, 07:39 PM   #2
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
Try to get the codes read and see what's going on?
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Old 04-30-2013, 07:39 PM   #3
Registered Member
Regular
 
TaylorF25's Avatar
 
Join Date: Jun 2011
Region: Florida
Posts: 296
Sounds like a bad coil pack, almost exactly how mine acted when mine went bad
TaylorF25 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-30-2013, 08:23 PM   #4
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Check for any break in the wires also.. Happened to me one wire was hitting the engine and sparking.. Made it drive like that
Xaperez100 is offline   Reply With Quote
Old 04-30-2013, 08:28 PM   #5
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Thx guys ill do some more searchin too
V6in is offline   Reply With Quote
Old 05-01-2013, 01:36 AM   #6
Registered Member
Regular
 
Join Date: Apr 2013
Location: Flat Rock
Region: Michigan
Posts: 27
What did it smell like? Was there any fluid on the ground, or anywhere in the engine bay?
NickieNay is offline   Reply With Quote
Old 05-01-2013, 04:10 AM   #7
Registered Member
Regular
 
Skargon's Avatar
 
Join Date: Aug 2012
Location: Tacoma
Region: Washington
Posts: 112
Just do a tune up, it's really easy on these 3.8's..

Plugs, wires, coil pack = less than 100$ bought all together..

Air filter, clean MAF, IAC, IAT, Etc.

Basically clean up everything and tune up things, even if the problem is solved, Its an old car with 100k+ Miles, tune up everything.
__________________

1998 Mustang V6
CAI, Exhaust, Weight Reduction
16.5 1/4 Mile
Skargon is offline   Reply With Quote
Old 05-01-2013, 05:15 PM   #8
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Ok but what's maf and iat and how do I clean them.

---------- Post added at 05:15 PM ---------- Previous post was at 05:14 PM ----------

Quote:
Originally Posted by NickieNay View Post
What did it smell like? Was there any fluid on the ground, or anywhere in the engine bay?
It wasn't oil or gas but it was almost like a musty smell. I can't recall smelling anything like it... It doesn't leak anything either.
V6in is offline   Reply With Quote
Old 05-01-2013, 05:27 PM   #9
Registered Member
Regular
 
Xaperez100's Avatar
 
Join Date: Dec 2012
Location: San antonio
Region: Texas
Posts: 1,230
Quote:
Originally Posted by V6in View Post
Ok but what's maf and iat and how do I clean them.

---------- Post added at 05:15 PM ---------- Previous post was at 05:14 PM ----------



It wasn't oil or gas but it was almost like a musty smell. I can't recall smelling anything like it... It doesn't leak anything either.
Mass airflow sensor and idle air control
Xaperez100 is offline   Reply With Quote
Old 05-03-2013, 11:34 PM   #10
Registered Member
Regular
 
Join Date: Apr 2013
Location: Flat Rock
Region: Michigan
Posts: 27
Quote:
It wasn't oil or gas but it was almost like a musty smell. . .
Was your grandpa still in it? :p

Jkjk
NickieNay is offline   Reply With Quote
Old 05-04-2013, 02:23 PM   #11
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Quote:
Originally Posted by NickieNay View Post

Was your grandpa still in it? :p

Jkjk
Lollll
V6in is offline   Reply With Quote
Old 05-11-2013, 09:28 PM   #12
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
So I fixed it, I'm pretty sure it was the coil pack. But I also put in new spark plugs and wires. And I went to auto zone to see why it said service engine soon light was still on and she said the #1 and #3 cylinders are misfiring. So I was wondering if that was from before or after what I did that made the cylinders misfire?
V6in is offline   Reply With Quote
Old 05-12-2013, 09:47 AM   #13
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Anyone?
V6in is offline   Reply With Quote
Old 05-12-2013, 09:59 AM   #14
Registered Member
Regular
 
twotone01's Avatar
 
Join Date: May 2012
Region: California
Posts: 420
Clear the codes and see if they come back and that'll let you know if you've fixed it or not haha
twotone01 is offline   Reply With Quote
Old 05-12-2013, 10:19 AM   #15
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Ok ill try that ha
V6in is offline   Reply With Quote
Old 05-12-2013, 05:51 PM   #16
Registered Member
Regular
 
V6in's Avatar
 
Join Date: Oct 2012
Region: Missouri
Posts: 362
Could the problem be from anything I did? Maybe cross the wires or something
V6in is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:01 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.