Cigar lighter problem ! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-24-2013, 10:11 PM   #1
Registered Member
Regular
 
Toolbox20's Avatar
 
Join Date: Apr 2013
Location: Mooresville
Region: North Carolina
Posts: 73
Exclamation Cigar lighter problem !

I have had this problem since ive owned the car , almost a year now !
Neither of the cigar lights worked , no idea on how to get them to work , checked all fuses , they all seem to be fine , still nothing !
No power running to the socket ! dont know what to do .
Any ideas ? !
Toolbox20 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-24-2013, 10:18 PM   #2
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
Wire could be frayed or torn. You're going to have to trace it as far as you can without removing the dash. I know the one in my center console doesn't work. I've taken out the center console and trace the wire, but no luck. It could be the lighter itself. You could try buying one at autozone or something and replace it to see if that's the problem. That was the problem in my ex mother in laws car. I crimped some new female connectors and got a new lighter and it worked perfectly
sam62893 is offline   Reply With Quote
Old 05-25-2013, 12:40 AM   #3
Registered Member
Regular
 
Toolbox20's Avatar
 
Join Date: Apr 2013
Location: Mooresville
Region: North Carolina
Posts: 73
I pulled out all fuses and put them back it , took my power tester an they both had power , put it all together , an they still worked , til I started the car an they stopped working .
An I don't have a stereo in my car right now , so the wires that are used to hard wire to a stereo , I taped them so no wires are exposed , an then the sockets started working , then I started it an it stopped .
Would it have to do with my battery ?
Cause my battery is slap dead , barely holds charge to it . I have to jump it off .
Toolbox20 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:32 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.