Why isnt my instrument cluster working ??! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-26-2013, 09:58 PM   #1
Registered User
Newbie
 
SlV6power's Avatar
 
Join Date: Apr 2013
Location: Nitro
Region: West Virgina
Posts: 12
Why isnt my instrument cluster working ??!

Well when I got my new pump installed in my car it worked well.then I turned it on the next time and my Low Fuel light was on And all my gauges except (tachometer,speedometer,voltagmeter) didn't work why did this happen help please

Click image for larger version

Name:	image-1137903719.jpg
Views:	107
Size:	399.9 KB
ID:	110583
SlV6power is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-26-2013, 10:08 PM   #2
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
What pump? The fuel pump?
sam62893 is offline   Reply With Quote
Old 05-26-2013, 11:21 PM   #3
Registered User
Newbie
 
SlV6power's Avatar
 
Join Date: Apr 2013
Location: Nitro
Region: West Virgina
Posts: 12
Yeah new fuel pump and jump started it a couple times
SlV6power is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-30-2013, 06:38 PM   #4
Registered Member
Regular
 
BattleBorn's Avatar
 
Join Date: May 2013
Location: Reno
Region: Nevada
Posts: 50
This once happened to my grandfather's F150, and it wasn't a pump. It turned out to be a blown fuse for the instrument cluster and nothing on there worked until the fuse was replaced. It could be something else, but that's just my two cents.
BattleBorn is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:13 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.