Intake problem - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-06-2013, 03:11 PM   #1
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Intake problem

After two years I have returned from the UK only to find that my Mustang is in a complete mess!
I noticed first that it has a revving problem (will periodically rev up to 2k when not in gear)
When I looked under the hood I noticed that there was a hose missing from my CAI
What is this hose? Where does it connect? I have attached a picture if that helps.
Attached Thumbnails
Click image for larger version

Name:	DSC01465.jpg
Views:	93
Size:	1.72 MB
ID:	112457  
blue-saleen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-06-2013, 03:30 PM   #2
Registered Member
Regular
 
Vsixpower's Avatar
 
Join Date: Apr 2013
Location: Sanantonio
Region: Texas
Posts: 80
That connects to the top of ur valve cover passenger side

---------- Post added at 03:30 PM ---------- Previous post was at 03:28 PM ----------

Check to see if u see a hole on the valve cover next to it. Correct me if I'm n e body
Vsixpower is offline   Reply With Quote
Old 06-06-2013, 06:41 PM   #3
Registered Member
Regular
 
willrad00's Avatar
 
Join Date: Oct 2011
Region: Wisconsin
Posts: 292
Yeah it should be your pcv hose
__________________
03 v6- black 17' 03 Cobra R deep dish wheels, AM short shifter, divorced duals with original 40's, windstar swap, and a tuner!
willrad00 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-07-2013, 12:17 PM   #4
Registered Member
Regular
 
blue-saleen's Avatar
 
Join Date: May 2009
Region: Utah
Posts: 244
Ah found it. Thank you! Mustang running normal again. Revving problem is gone.
blue-saleen is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:38 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.