lost Speedo, Odometer and Accessories. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-16-2013, 10:34 AM   #1
Registered User
Newbie
 
MyStang96's Avatar
 
Join Date: Jun 2013
Location: Rentom
Region: Washington
Posts: 1
lost Speedo, Odometer and Accessories.

Morning and Happy Fathers day #Stang Fans!
Yesterday I installed a new Radio in Kitt which worked fine for all of Ten minutes and cut out... Taking my Speedo, Odometer, Trip planner, power mirrors, dome light and clock. The Weird thing is i checked all the Fuses and even check the power output in the wires no blown fuses but the power wire for radio has no spark at all I was thinking at first it was my VSS or the Gears in the odometer but I have not gotten it out yet what has me all messed up is the fact that i lost the power accessories cause all the other ones work which are on the same power supply wipers, ac, chime etc. Plus all my gauges work correctly gas, Tact, oil everything but speedo and odometer.
If you could help me out with any info that would be amazing Kitt 1996 V6 stock set up.
MyStang96 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:17 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.