Springs - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-01-2013, 05:53 PM   #1
Registered Member
Regular
 
94sccoupe's Avatar
 
Join Date: Apr 2012
Region: West Virgina
Posts: 240
Springs

Has anyone here bought the sve lowering springs from late model

Click image for larger version

Name:	ForumRunner_20130701_185311.png
Views:	72
Size:	490.0 KB
ID:	116352

resto. I'm not liking the drop at all. Suppose to have been a 2" drop must have been on a v8
94sccoupe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2013, 10:37 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
if you left your ISO's in then pull them...
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 07-02-2013, 12:25 AM   #3
Registered Member
Regular
 
Doe_Rae_mi's Avatar
 
Join Date: Nov 2011
Region: South Carolina
Posts: 2,587
Quote:
Originally Posted by 94sccoupe
Has anyone here bought the sve lowering springs from late model

resto. I'm not liking the drop at all. Suppose to have been a 2" drop must have been on a v8
Maybe they were installed wrong?
Doe_Rae_mi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2013, 04:19 AM   #4
Registered Member
Regular
 
94sccoupe's Avatar
 
Join Date: Apr 2012
Region: West Virgina
Posts: 240
Quote:
Originally Posted by 1slosix View Post
if you left your ISO's in then pull them...
Yeah I wanted to take them out the other day when it was getting worked on the other day. But I let the mechanic talk me out of it. He started talking about metal on metal so I changed my mind. I'm going to at least try it
94sccoupe is offline   Reply With Quote
Old 07-02-2013, 08:58 AM   #5
Registered Member
Regular
 
94sccoupe's Avatar
 
Join Date: Apr 2012
Region: West Virgina
Posts: 240
Quote:
Originally Posted by Doe_Rae_mi View Post

Maybe they were installed wrong?
How could they have been installed wrong
94sccoupe is offline   Reply With Quote
Old 07-02-2013, 11:05 AM   #6
Registered Member
Regular
 
Doe_Rae_mi's Avatar
 
Join Date: Nov 2011
Region: South Carolina
Posts: 2,587
Quote:
Originally Posted by 94sccoupe View Post

How could they have been installed wrong
Idk thats why I put a question mark on it lol
Doe_Rae_mi is offline   Reply With Quote
Old 07-02-2013, 02:11 PM   #7
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
If they were not installed the same way as pulled out it'd cause this issue. Its hard to do it wrong but it does happen. And this is why I don't use shops for work. They always wanna talk you out of things lol.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:38 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.