slight overheating on hot days - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-03-2013, 04:58 PM   #1
Registered Member
Regular
 
hepler02's Avatar
 
Join Date: Mar 2013
Location: belleville
Region: New Jersey
Posts: 86
slight overheating on hot days

So my car has started to get hot a few times on hot days..mainly on days I havent used the a.c. which I know happens to ppl often when they do use the a.c. so thats kinda odd. My passenger manifold has been cracked for a while nd Ive been procrastinating on getting headers.. could this have anything to do w it? A while ago my car was getting really hot so my mechanic welded my passenger side manifold nd replaced the thermostat sensor. After that I had no problem. So not sure of it could have something to do w the f'ed up manifold. I heard from someone the two r unrelated.. any suggestions? I wanted to drive to p.a. in a week and now Im thinking twice..dont wana make matters worse

---------- Post added at 03:58 PM ---------- Previous post was at 03:57 PM ----------

Also car has not fully overheated nd died..lately its just a little past the middle
hepler02 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-03-2013, 06:19 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Swap thermostats and add water...make sure you bleed the system of air. Sounds like its just sticking a bit sometimes.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 07-03-2013, 06:20 PM   #3
Registered Member
Regular
 
Robbiemustang96's Avatar
 
Join Date: Nov 2011
Region: Illinois
Posts: 622
do you have a aftermarket tempature gauge?
Robbiemustang96 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-03-2013, 06:40 PM   #4
Registered Member
Regular
 
hepler02's Avatar
 
Join Date: Mar 2013
Location: belleville
Region: New Jersey
Posts: 86
Just aftermarket sensor...unless the person before me did something to it idk...
hepler02 is offline   Reply With Quote
Old 07-03-2013, 07:11 PM   #5
Registered Member
Regular
 
hepler02's Avatar
 
Join Date: Mar 2013
Location: belleville
Region: New Jersey
Posts: 86
I feel like he coulda replaced the thermostat. Maybe Im confusing myself I gotta call him.. damn car!

---------- Post added at 06:11 PM ---------- Previous post was at 06:07 PM ----------

Ha ok no it was the temp sensor. Sorry
hepler02 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:56 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.