4.6 GT CAI on single port 3.8? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-07-2013, 01:10 AM   #1
Registered Member
Regular
 
lemons95's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 835
4.6 GT CAI on single port 3.8?

The wrecked GT I picked up has a BBK cai, I took it off and it lines up with my intake I have on it now.
As long as it connects to the intake and the wire hook up it will work right?

Until I get the funds and time for the engine swap I'm swapping small stuff. I'm going to be swapping the rearend soon.
lemons95 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2013, 01:36 AM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Yes it'll work just put your MAF on it and you're good to go. May need to buy a new coupler to put it to your TB though.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 07-08-2013, 01:40 AM   #3
Registered Member
Regular
 
lemons95's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 835
It fit on it easily, had one hole that I didn't have. Coupling had to be tightened a little more than it was on the GT.
I dropped the maf, while it was in the housing, it was on the front bumper by the chrome pony. I thought since it was such a small drop that it would probably be fine, just picked it back up and installed it. Car ran like ****... kept dying the first few times had no power and struggled to do 2000 rpms. My dad thought it might of been the extra hole in the intake since it ran like it wasn't getting enough fuel. I thought maybe I broke the MAF, a new MAF cost $70 and a can of MAF cleaner cost $7, luckily it was just dirty. Runs ALOT better now.
We both were kinda stumped for a few hours until I remembered that I dropped the maf lol.
I was confused because it's just a tube that air goes through, "WTF COULD BE WRONG WITH A METAL TUBE!" everythings fine now.
lemons95 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Tags
cai

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:25 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.