CAI filter isn't staying on - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-19-2013, 04:39 PM   #1
Registered Member
Regular
 
RedMustang's Avatar
 
Join Date: Jul 2013
Location: Russellville
Region: Arkansas
Posts: 38
CAI filter isn't staying on

I know the first thing you're gonna say is tighten it down. I have! As much as I possibly can, but it still falls off. 4 times so far, luckily not while I was driving. I want to get it on once and for all, but still be able to remove it for cleaning. What would be ideal for this? Maybe some silicone? Any ideas?
RedMustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-19-2013, 04:40 PM   #2
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
Maybe the clamp isn't working? Do you feel it tighten? Or does it slip?
sam62893 is offline   Reply With Quote
Old 07-19-2013, 04:45 PM   #3
Registered Member
Regular
 
RedMustang's Avatar
 
Join Date: Jul 2013
Location: Russellville
Region: Arkansas
Posts: 38
This last time, I tightened it as tight as I possibly could and then I tried everything I could to make it fall off, it held tight, so I installed it back on car, started and ran car for 5 minutes and then it fell off! The clamp seems fine and i can clearly see it tighten down to the filter.
RedMustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-19-2013, 05:30 PM   #4
Registered Member
Regular
 
RedMustang's Avatar
 
Join Date: Jul 2013
Location: Russellville
Region: Arkansas
Posts: 38
Ok I feel like an idiot now. I figured out what the wide chrome clamp is used for! Holding and securing the air filter in place! Problem should be solved now!
RedMustang is offline   Reply With Quote
Old 07-19-2013, 06:00 PM   #5
Registered Member
Regular
 
sam62893's Avatar
 
Join Date: Jul 2012
Location: Colton
Region: California
Posts: 2,029
Well, yeah that's what it does, it clamps the filter to the metal tube >.>
sam62893 is offline   Reply With Quote
Old 07-19-2013, 06:04 PM   #6
Sad Panda
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,633
Quote:
Originally Posted by RedMustang View Post
Ok I feel like an idiot now. I figured out what the wide chrome clamp is used for! Holding and securing the air filter in place! Problem should be solved now!
live & learn
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Tags
cai

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:27 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.