Possible Fuel Pressure issues - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-22-2013, 11:30 AM   #1
Registered User
Newbie
 
Join Date: Nov 2013
Location: Houston
Region: Texas
Posts: 2
Possible Fuel Pressure issues

Before I get into the issue, I know that my fuel pump needs to be replaced as it seems to be going out due to sporadic drops in RPMs while moving

My car is a 1995, base model, 5 speed. When I get in to start it up after it has been sitting for a extended amount of time 2+ hours the engine will take a while to turn over I believe due to a lack of fuel pressure. However if the car is only off for less than that time, I typically do not have an issue starting it. The problem is also more noticeable when it is parked with the nose in the air.

I have discovered that if i try to turn it over, then immediately turn it off and try again, it starts up fine. When checking out my engine bay the other day, I noticed that one of the fuel lines had backed off its connection to the fuel rails by about 6-7 mm compared to the other one right next to, i pushed it back on.

One last thing, there is no noticeable fuel odor emanating from my car, fuel filter was replaced ~4 months ago. Can anyone shed some light on my car's issues
midsprat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-22-2013, 04:28 PM   #2
Registered Member
Regular
 
samuelsmith's Avatar
 
Join Date: Feb 2013
Location: Gulfport
Region: Mississippi
Posts: 1,234
Plug it in at Auto Zone and get some data log information.
__________________

new engine,1.7 rocker arms,Pipes exhaust, shorty cats , shorty headers,under drive and overdrive pulleys,4.2 upper plenum, throttle body spacer, cold air intake, stage one clutch, shorty shifter, and tune. 8.8 in storage
samuelsmith is offline   Reply With Quote
Old 11-22-2013, 05:05 PM   #3
Registered User
Newbie
 
Join Date: Nov 2013
Location: Houston
Region: Texas
Posts: 2
Even if the car is obd-I?
midsprat is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:28 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.