whyyy, stilllll overheating!! anymore ideas? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-17-2013, 11:24 AM   #1
Registered User
Newbie
 
Join Date: Dec 2013
Location: Kentland
Region: Indiana
Posts: 18
whyyy, stilllll overheating!! anymore ideas?

ok so ive bled the cooling system like, 12 times, she ran fine for about 30 mins then overheated again, i let her cool down and bled the lines again, but now she stilllll overheats driving short distances! once i get on the highway about 60-65 she cools back down! could there be another pressure valve somewhere i need to bleed?? any suggestions would help!
wootman101 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2013, 11:28 AM   #2
Registered Member
Regular
 
03Graymach's Avatar
 
Join Date: Oct 2013
Location: Brenham
Region: Texas
Posts: 328
Quote:
Originally Posted by wootman101 View Post
ok so ive bled the cooling system like, 12 times, she ran fine for about 30 mins then overheated again, i let her cool down and bled the lines again, but now she stilllll overheats driving short distances! once i get on the highway about 60-65 she cools back down! could there be another pressure valve somewhere i need to bleed?? any suggestions would help!
are you fans coming on cause it sounds like your not getting enough wind though the engine bay to move out to hot air
03Graymach is offline   Reply With Quote
Old 12-17-2013, 11:41 AM   #3
Registered Member
Regular
 
JimmyMosqueda's Avatar
 
Join Date: Jun 2013
Location: Houston
Region: Texas
Posts: 270
Get rid of your hood. Boom. Next problem!
JimmyMosqueda is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2013, 11:43 AM   #4
Registered User
Newbie
 
Join Date: Dec 2013
Location: Kentland
Region: Indiana
Posts: 18
ya the fan kicks on good, i just noticed the hose that goes from the bottom driver side of the radiator is stiff as hell though, i dont think its supposed to be hard?
wootman101 is offline   Reply With Quote
Old 12-17-2013, 11:43 AM   #5
Registered Member
Regular
 
mystang50's Avatar
 
Join Date: Jul 2011
Location: houston
Region: Texas
Posts: 1,201
Quote:
Originally Posted by 03Graymach View Post
are you fans coming on cause it sounds like your not getting enough wind though the engine bay to move out to hot air
x2!!
__________________
1995 5.0 u/d,cai,t/b,shorty headers,x pipe,flows 40's,373 gears, alum. driveshaft, alum. radiator, shift kit, e-cam, ported upper and lower intake, 100 shot of spray, 2100 stall, black 0304 cobras. suspension: upper and lower control arms, sub frame connecters, and springs all SVE
mystang50 is offline   Reply With Quote
Old 12-17-2013, 11:44 AM   #6
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Yep, check the e-fans for proper operation. Idling in the driveway, they should kick on when the temp gets to halfway.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 12-17-2013, 11:46 AM   #7
Registered User
Newbie
 
Join Date: Dec 2013
Location: Kentland
Region: Indiana
Posts: 18
haha ya im bout to just get rid of the whole damn thing!

---------- Post added at 11:46 AM ---------- Previous post was at 11:44 AM ----------

like whenever i bleed the system, the heat works great in the car for about 10 mins then it gets cold again and the car starts overheating again, then i have to let it cool down and bleed it again, i know someone said there could be more than on pressure valve but the only one i know of is right above the water pump
wootman101 is offline   Reply With Quote
Old 12-17-2013, 12:04 PM   #8
Registered Member
Regular
 
mystang50's Avatar
 
Join Date: Jul 2011
Location: houston
Region: Texas
Posts: 1,201
have you checked your t-stat? could be gunked up with trash or something that keeps getting recirculated? or could be on backwards.

---------- Post added at 12:04 PM ---------- Previous post was at 12:02 PM ----------

Quote:
Originally Posted by mystang50 View Post
have you checked your t-stat? could be gunked up with trash or something that keeps getting recirculated? or could be on backwards.
what about the pump? could be eroded from tap water.
__________________
1995 5.0 u/d,cai,t/b,shorty headers,x pipe,flows 40's,373 gears, alum. driveshaft, alum. radiator, shift kit, e-cam, ported upper and lower intake, 100 shot of spray, 2100 stall, black 0304 cobras. suspension: upper and lower control arms, sub frame connecters, and springs all SVE
mystang50 is offline   Reply With Quote
Old 12-17-2013, 12:11 PM   #9
Registered Member
Regular
 
03Graymach's Avatar
 
Join Date: Oct 2013
Location: Brenham
Region: Texas
Posts: 328
Quote:
Originally Posted by wootman101 View Post
haha ya im bout to just get rid of the whole damn thing! ---------- Post added at 11:46 AM ---------- Previous post was at 11:44 AM ---------- like whenever i bleed the system, the heat works great in the car for about 10 mins then it gets cold again and the car starts overheating again, then i have to let it cool down and bleed it again, i know someone said there could be more than on pressure valve but the only one i know of is right above the water pump
Should be another on near the thermostat
03Graymach is offline   Reply With Quote
Old 12-17-2013, 12:20 PM   #10
Registered User
Newbie
 
Join Date: Dec 2013
Location: Kentland
Region: Indiana
Posts: 18
ok guys thanks, i just remembered someone said to jack up the front end and thennn bleed it, i havent tried that either, i think she might have to wait til it warms up a bit though its been under 30 degrees alllll freakin week. gonna try to push her into the garage and see what i can do
wootman101 is offline   Reply With Quote
Old 12-18-2013, 02:07 AM   #11
Registered Member
Regular
 
davidcseifert's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 1,694
How are you bleeding it... You shouldn't have to jack it up if you're doing the procedure right
__________________

BV heads, P&P lower, comp 218/226 cam, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, SCT xcal2 (93 Ortizperformance tune), Windstar upper, 65mm tb, CAI, 8.8 w/ 3.73's, SFC's, cut springs, KYB shocks/struts, MM LCA's
blower/new cam soon
Dealer for Ortiz Performance, great tunes at a good price!
davidcseifert is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:37 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.