abs+traction light on troubleshooting help - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-09-2014, 09:56 PM   #1
Registered Member
Regular
 
speedshop23's Avatar
 
Join Date: Dec 2013
Location: lima
Region: Ohio
Posts: 42
abs+traction light on troubleshooting help

ok so about 45 minutes ago I was trying to leave work and the parking lot was ice with slush covered over it, I allways turn traction off so i can try to get out of snow and such, well I was spinning some but it was one wheel peeling and i pressed on the brake to try to help get it to enguage my drivers side tire and it didnt help me, well I finally got out and looked down and my abs light was on, so I drove home and while on the highway I tried to turn my traction control back on multiple times , button stayed illuminated and would go back to normal settings, and my abs is stuck on too. tryed turning car off and on multiple times,,,, Still there, even unppluged battery for 20 mins and put back in,,, still does it,,, So im stumped,

Any ideas of why its on, Im thinking it might be like snow in the abs sensor but won't find that out till i go to school tommarrow and put it on the rack.

also I left my code reader in my toolbox at school , normally I put the box in my trunk for extra weight but i forgot but

anyways , guys, anyone had this problem or knows what to check for and or how to fix it
speedshop23 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-09-2014, 10:47 PM   #2
Registered Member
Regular
 
Screaming Mach's Avatar
 
Join Date: Aug 2013
Location: Lebanon
Region: Missouri
Posts: 857
Quote:
Originally Posted by speedshop23 View Post
ok so about 45 minutes ago I was trying to leave work and the parking lot was ice with slush covered over it, I allways turn traction off so i can try to get out of snow and such, well I was spinning some but it was one wheel peeling and i pressed on the brake to try to help get it to enguage my drivers side tire and it didnt help me, well I finally got out and looked down and my abs light was on, so I drove home and while on the highway I tried to turn my traction control back on multiple times , button stayed illuminated and would go back to normal settings, and my abs is stuck on too. tryed turning car off and on multiple times,,,, Still there, even unppluged battery for 20 mins and put back in,,, still does it,,, So im stumped,

Any ideas of why its on, Im thinking it might be like snow in the abs sensor but won't find that out till i go to school tommarrow and put it on the rack.

also I left my code reader in my toolbox at school , normally I put the box in my trunk for extra weight but i forgot but

anyways , guys, anyone had this problem or knows what to check for and or how to fix it
I'm going to say its probably a sensor dirty definitely check those first ! For me it is not so simple it's my abs module so I had mine turned off so I have no abs or traction control witch I like way more lol
Screaming Mach is offline   Reply With Quote
Old 01-10-2014, 11:35 AM   #3
Registered Member
Regular
 
Blakhwk's Avatar
 
Join Date: Mar 2012
Region: Pennsylvania
Posts: 321
you have to check the sensors and make sure all of them are clean and the wires are not loose.
I had the same problem but after checking all these stuff it was the module, I bought one over ebay for $90 bucks and replaced it myself, problem solved.

good luck.
Blakhwk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-10-2014, 03:34 PM   #4
Registered Member
Regular
 
speedshop23's Avatar
 
Join Date: Dec 2013
Location: lima
Region: Ohio
Posts: 42
We'll I looking at the rear drivers sensor today and it looked clean , went and washed it inside with cleaner and cleaned around where it went and made sure connections were good, put back together and still was on we'll drove around a bit and it went off finally , so my light isn't on anymore so I hope I fixed the problem
speedshop23 is offline   Reply With Quote
Old 01-10-2014, 04:44 PM   #5
Registered Member
Regular
 
Blakhwk's Avatar
 
Join Date: Mar 2012
Region: Pennsylvania
Posts: 321
I think you should be good.
__________________
Visca Barça
Blakhwk is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS light + traction control doesnt work RedGT04 1996-2004 Mustang GT 16 11-12-2015 07:43 PM
ABS Light is on. jubileephoto 1996-2004 Mustang GT 6 11-30-2011 02:22 PM
Abs light? Gigerdavid 1996-2004 Mustang GT 3 10-30-2011 12:47 PM
ABS and Track off light On Siendly22 General Mustang Discussion 1 10-18-2011 06:19 PM
ABS light on and track off Siendly22 2005-2010 V6 Mustang 0 10-14-2011 12:51 AM

» Like Us On Facebook



06:40 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.