Car has very bad throttle lag - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-14-2014, 10:18 PM   #1
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Car has very bad throttle lag

Wats up guys, I just got my car back from the body shop earlier. I noticed my car has a very bad throttle lag like to the point I step on the gas and either it picks up very very very slow or it just doesn't pick up until after a few seconds. I know for sure it was not like this before I dropped it off. Only thing that they should have done besides replacing my bumpers is wire splicing for my fog lights. Which required them to disconnect the battery. I'm not sure wars going in just need some input
comporange is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2014, 10:30 PM   #2
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Car has very bad throttle lag

Wats up guys, I just got my car back from the body shop earlier. I noticed my car has a very bad throttle lag like to the point I step on the gas and either it picks up very very very slow or it just doesn't pick up until after a few seconds. I know for sure it was not like this before I dropped it off. Only thing that they should have done besides replacing my bumpers is wire splicing for my fog lights. Which required them to disconnect the battery. I'm not sure wars going in just need some input
comporange is offline   Reply With Quote
Old 03-15-2014, 11:51 AM   #3
Registered Member
Regular
 
samuelsmith's Avatar
 
Join Date: Feb 2013
Location: Gulfport
Region: Mississippi
Posts: 1,234
Does the check engine light come on?
__________________

new engine,1.7 rocker arms,Pipes exhaust, shorty cats , shorty headers,under drive and overdrive pulleys,4.2 upper plenum, throttle body spacer, cold air intake, stage one clutch, shorty shifter, and tune. 8.8 in storage
samuelsmith is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2014, 02:32 PM   #4
Registered Member
Regular
 
kickerofdoom's Avatar
 
Join Date: Mar 2011
Region: Maryland
Posts: 1,868
Seafoam it
kickerofdoom is offline   Reply With Quote
Old 03-15-2014, 10:57 PM   #5
Registered Member
Regular
 
baddbradd's Avatar
 
Join Date: Oct 2010
Location: Hueytown, Alabama
Region: Alabama
Posts: 177
computer may have to re-learn some stuff since the batt. was disconnected. Should be fine in a day or so.....Unless they beat the sh@t outta it lol
__________________
2001 coupe
baddbradd is offline   Reply With Quote
Old 03-16-2014, 12:24 AM   #6
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Quote:
Originally Posted by baddbradd View Post
computer may have to re-learn some stuff since the batt. was disconnected. Should be fine in a day or so.....Unless they beat the sh@t outta it lol

Lol right hopefully they didn't
comporange is offline   Reply With Quote
Old 03-16-2014, 12:26 AM   #7
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Quote:
Originally Posted by kickerofdoom View Post
Seafoam it

Thanks man I'm look into sea foaming. It just dosen't make sense to it was perfectly find when I dropped it off the next day when I got it back the problem was there, I'm very confused

---------- Post added at 12:26 AM ---------- Previous post was at 12:26 AM ----------

Quote:
Originally Posted by samuelsmith View Post
Does the check engine light come on?

NOPE!! No codes are being thrown
comporange is offline   Reply With Quote
Old 03-17-2014, 05:36 PM   #8
Registered Member
Regular
 
whiteshirt99's Avatar
 
Join Date: Jan 2014
Posts: 54
Could be plugs loose went to the front pushed a couple it stopped so I changed spark plugs and sea foamed it and changed plug wire haven't had a problem since
whiteshirt99 is offline   Reply With Quote
Old 03-19-2014, 01:16 PM   #9
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Update: went to start the car an hour ago, car did not start didn't even click over. So I got a jump from my sister car and 20 mins into my drive my car automatically turns the volume of the radio down twice so I cut the radio off. Than I put my left signal on and slow down to make the turn the car acts like it wants to cut off, all the dash lights came on like when your turning the car on my gas and speedometer dropped to zero. Rite as I pull-up to work she goes dead in the parking lot. I give it a jump and start it up and cut it off and when I cut it back on it clicked but barley wanted to start... I need help on wat the issue could be thank you guys, btw I recently put a cobra bumper on with the fogs if u think that would make a difference. I didn't have fogs before
comporange is offline   Reply With Quote
Old 03-19-2014, 02:05 PM   #10
Registered Member
Regular
 
OfficialMakkyZ's Avatar
 
Join Date: Mar 2014
Location: Oklahoma City
Region: Oklahoma
Posts: 270
Quote:
Originally Posted by comporange View Post
Update: went to start the car an hour ago, car did not start didn't even click over. So I got a jump from my sister car and 20 mins into my drive my car automatically turns the volume of the radio down twice so I cut the radio off. Than I put my left signal on and slow down to make the turn the car acts like it wants to cut off, all the dash lights came on like when your turning the car on my gas and speedometer dropped to zero. Rite as I pull-up to work she goes dead in the parking lot. I give it a jump and start it up and cut it off and when I cut it back on it clicked but barley wanted to start... I need help on wat the issue could be thank you guys, btw I recently put a cobra bumper on with the fogs if u think that would make a difference. I didn't have fogs before

Check the wiring, sounds like they shorted something and didn't want to have to fix it. Or they f-ed up your alternator.
__________________
Check out my garage:

http://www.mustangevolution.com/forum/f376/t351203/

OfficialMakkyZ is offline   Reply With Quote
Old 03-19-2014, 02:35 PM   #11
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
This is Easy

You have a bad cell in your battery You need to charge it up and have someone check for a bad cell.
Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 03-19-2014, 04:30 PM   #12
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Ok thanks guys I'm taking her to pep boys tomorrow to get some test ran. The car is under warranty so if it's the alternator I will get a new 1 or just pay out right for a new battery but I hope that's it.
comporange is offline   Reply With Quote
Old 03-20-2014, 02:47 PM   #13
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Took the car to get looked at and nothing but a mass air flow sensor was unplugged so that caused all the issues
comporange is offline   Reply With Quote
Old 03-20-2014, 03:12 PM   #14
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
Good


Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 03-20-2014, 03:25 PM   #15
Site Sponsor
Sponsor
 
AMWill's Avatar
 
Join Date: Apr 2012
Location: Malvern
Region: Pennsylvania
Posts: 2,171
Quote:
Originally Posted by comporange View Post
Took the car to get looked at and nothing but a mass air flow sensor was unplugged so that caused all the issues
That will certainly do it! Even a dirty MAF can cause a car to run rough, let along a disconnected one. At point, your Mustang was just running on a half calibrated speed density map. As these cars use the MAF full time.

Anyways, glad you got it figured out! How did the work at the body shop turn out?

Shane
__________________
Will Levantovsky | AmericanMuscle.com
Toll Free: 866.727.1266
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A $1500 MMD STYLING PACKAGE
Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 03-20-2014, 04:05 PM   #16
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Quote:
Originally Posted by AMShaneLesky View Post
That will certainly do it! Even a dirty MAF can cause a car to run rough, let along a disconnected one. At point, your Mustang was just running on a half calibrated speed density map. As these cars use the MAF full time.



Anyways, glad you got it figured out! How did the work at the body shop turn out?



Shane

Lol yea it felt like it it was slow as ever lol. It turned out good here's a few pics
Click image for larger version

Name:	ImageUploadedByMustang Evolution1395349446.629004.jpg
Views:	121
Size:	261.7 KB
ID:	151279Click image for larger version

Name:	ImageUploadedByMustang Evolution1395349473.466664.jpg
Views:	133
Size:	722.7 KB
ID:	151280
I'll be ordering the matte blk mustang letters next week to go on the back bumper from AM
comporange is offline   Reply With Quote
Old 03-21-2014, 03:43 PM   #17
Site Sponsor
Sponsor
 
AMWill's Avatar
 
Join Date: Apr 2012
Location: Malvern
Region: Pennsylvania
Posts: 2,171
Quote:
Originally Posted by comporange View Post
Lol yea it felt like it it was slow as ever lol. It turned out good here's a few pics
Attachment 151279Attachment 151280
I'll be ordering the matte blk mustang letters next week to go on the back bumper from AM
Good stuff! I agree, black letter inserts would be a nice touch to the rear bumper. I like all of the black accents throughout the car too. Red by itself just doesn't look as good or sinister.

Feel free to hit me up if you ever have questions about any of our AM products too. I'm here to help!
__________________
Will Levantovsky | AmericanMuscle.com
Toll Free: 866.727.1266
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A $1500 MMD STYLING PACKAGE
Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 03-21-2014, 03:58 PM   #18
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Quote:
Originally Posted by AMShaneLesky View Post
Good stuff! I agree, black letter inserts would be a nice touch to the rear bumper. I like all of the black accents throughout the car too. Red by itself just doesn't look as good or sinister.



Feel free to hit me up if you ever have questions about any of our AM products too. I'm here to help!

Thanks man, yea it would look rite at home on the bumper.
comporange is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Plasti Dip Your Car (In Depth, 6 pages worth of Microsoft Word) Topless04GT Mustang Paint, Appearance & Detailing 318 05-17-2017 01:40 PM
Mustang 2 motor swap. Curtiswhitehead 2.3 Mustang 2 07-10-2013 09:06 AM
cars are better than women BUSHGUTS The Bar 25 11-21-2012 12:07 PM
Horrible stangs we've all seen em Dgibson Pictures and Videos 225 05-15-2012 10:29 PM
62mm bore throttle bodies on naturally aspirated 05-09 mustangs 08 Bullitt 2005-2010 Mustang GT 40 01-16-2012 02:36 PM

» Like Us On Facebook



11:04 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.