Squeak coming from front end??? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-05-2014, 06:37 AM   #1
Registered User
Newbie
 
SLiM2775's Avatar
 
Join Date: Feb 2014
Location: Lansdale
Region: Pennsylvania
Posts: 19
Squeak coming from front end???

I have a squeak coming from the front end when I turn the steering wheel at low speeds and sometimes when going over speed bumps. It doesnt do it when I push on the front of the car thou so I dont think its a bushing. Im thinking it might be my power steering pump?? If anyone has any advice on how to find where it is coming from that would be great. Thanks in advance.
__________________

2001 3.8
SR CAI
JVC Head Unit, 1000 Watt Pioneer Amp, Two 10" Pioneer Subs.
SLiM2775 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-05-2014, 08:41 AM   #2
Registered Member
Regular
 
mazen123's Avatar
 
Join Date: Apr 2014
Posts: 248
Nope its either your strut mount or ball joint. I had the same exact problem in the winter! How many miles on your car? And are the ball joints/ strut mounts original?
mazen123 is offline   Reply With Quote
Old 05-07-2014, 06:23 AM   #3
Registered User
Newbie
 
SLiM2775's Avatar
 
Join Date: Feb 2014
Location: Lansdale
Region: Pennsylvania
Posts: 19
Quote:
Originally Posted by mazen123 View Post
Nope its either your strut mount or ball joint. I had the same exact problem in the winter! How many miles on your car? And are the ball joints/ strut mounts original?
It has 173,000 on it, and I think they are the original, but I could be wrong I bought the car used. How hard would they be to replace? And I am not a mechanic, I work at a Quick Lube place where we do have a lift. If I wanted to have a garage do it what would you think they would charge for something like that, I know it all depends on where I go, I just need a ruff idea so I know I am not getting ripped off, Im taking it to be inspected on Friday so I am gonna have them take a look at it and go from there. But if its a easy job that can be done in a day without special tools then maybe I could try it myself. Any advice would be great.
__________________

2001 3.8
SR CAI
JVC Head Unit, 1000 Watt Pioneer Amp, Two 10" Pioneer Subs.
SLiM2775 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2014, 06:25 AM   #4
Registered Member
Regular
 
mazen123's Avatar
 
Join Date: Apr 2014
Posts: 248
Itll be around 100-150 installed. It could also be your strut mounts, which would be around 150-200 installed
mazen123 is offline   Reply With Quote
Old 05-07-2014, 06:27 AM   #5
Registered Member
Regular
 
mazen123's Avatar
 
Join Date: Apr 2014
Posts: 248
I had strut mounts installed for about 180 and both ball joints installed for around 100 each. They all went bad because of the gruesome winter we had, the cold temperatures dried out the lubrication of the joints and mounts causing them to die prematurely, they were getting old though, i have 100,000 miles
mazen123 is offline   Reply With Quote
Old 05-08-2014, 05:52 AM   #6
Registered User
Newbie
 
SLiM2775's Avatar
 
Join Date: Feb 2014
Location: Lansdale
Region: Pennsylvania
Posts: 19
Thats not bad, but how come it only does it when the car is warmed up and only at low speeds and while not moving??? And if I get out and push and rock the front end it doesnt make the sound at all......Im confused....
__________________

2001 3.8
SR CAI
JVC Head Unit, 1000 Watt Pioneer Amp, Two 10" Pioneer Subs.
SLiM2775 is offline   Reply With Quote
Old 05-09-2014, 09:59 PM   #7
Registered Member
Regular
 
mummert_96v6's Avatar
 
Join Date: May 2013
Location: new oxford
Region: Pennsylvania
Posts: 281
Quote:
Originally Posted by SLiM2775 View Post
I have a squeak coming from the front end when I turn the steering wheel at low speeds and sometimes when going over speed bumps. It doesnt do it when I push on the front of the car thou so I dont think its a bushing. Im thinking it might be my power steering pump?? If anyone has any advice on how to find where it is coming from that would be great. Thanks in advance.

I had the exact same problem with my 96 it was the ball joint so I'd start there
mummert_96v6 is offline   Reply With Quote
Old 05-14-2014, 07:00 AM   #8
Registered User
Newbie
 
SLiM2775's Avatar
 
Join Date: Feb 2014
Location: Lansdale
Region: Pennsylvania
Posts: 19
Sound is Gone?????

I just got my car inspected and he said the ball joints are still good, and also the sound went away about a week before I got inspected, and it has not come back, so Im confused, but happy. I had to put a grand out for it to pass inspection thou, it needed both rear calipers because the old ones where hanging up and I had to have both rear brake cables replaced, plus the new brake pads and a new head light housing because I had moister in the one. But my car has better pick up now that the rear brakes are not hung up!!!! It was the inside pad that was stuck on, it really only needed the driver side caliper but I figured I might as well do both.
__________________

2001 3.8
SR CAI
JVC Head Unit, 1000 Watt Pioneer Amp, Two 10" Pioneer Subs.
SLiM2775 is offline   Reply With Quote
Old 05-14-2014, 03:20 PM   #9
Registered Member
Regular
 
mazen123's Avatar
 
Join Date: Apr 2014
Posts: 248
Good for u man, thats great
mazen123 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake/Rear end squeak?!?!?! 08mustanggt 2005-2010 Mustang GT 14 08-12-2015 12:24 AM
Weird sound coming from mid front end PISTONS8904 2011-2014 Mustang GT 9 06-10-2013 01:40 PM
86 front end into an 89 front end Beatjunkiexorge 2.3 Mustang 1 05-18-2013 08:07 PM
Squeak Noise coming from Brakes Stang23 2005-2010 Mustang GT 5 11-08-2012 12:36 PM
Passenger side rear end squeak?? SuperDave2010 1996-2004 Mustang GT 4 03-09-2010 02:18 PM

» Like Us On Facebook



05:46 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.