Start and PATS issues - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-19-2014, 01:47 PM   #1
Registered User
Newbie
 
Join Date: Jun 2014
Location: Hyden
Region: Kentucky
Posts: 2
Start and PATS issues

Hey guys,

I am the proud honor of a 2003 Stang that has recently given me some issues. It has quit on me twice and drained the battery. The alternator and battery are okay. I just recently noticed the theft light blinking. I tried to start the car this morning but surprise: my battery was almost dead again. The theft light is blinking and there is a buzzing noise coming from the area of the steering wheel.

Please help.
revgregdavidson is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PATS transceiver and control modules 98v6stang101 Pre-2005 V6 Mustang 0 03-04-2008 09:47 PM
w00t, pats 13-2 Rellik The Bar 4 12-27-2003 09:18 PM
Help, PATS is driving me crazy!! Rick0636 Pre-2005 V6 Mustang 10 10-31-2003 06:02 AM
pats pats pats! Rellik The Bar 14 08-08-2003 06:04 PM

» Like Us On Facebook



05:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.