Loud screeching noise when I turn left?? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-24-2014, 08:43 AM   #1
Registered User
Newbie
 
Stang_life3's Avatar
 
Join Date: May 2014
Location: Charlotte
Region: North Carolina
Posts: 7
Loud screeching noise when I turn left??

So I've recently heard a loud screeching noise coming from my front end. I only hear it when I turn left, go over speed bumps, and accelerate from a dead stop. It's not my power steering because I put the front end on jacks and turned the wheel around but there was no noise. I jerked the wheels around and spun them while I had it up but nothing. I'm starting to think it's a bad tie rod. Any other suggestions? It's a 1999 3.8 auto


Sent from my iPhone using Mustang Evolution
Stang_life3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-28-2014, 08:58 AM   #2
Registered Member
Regular
 
Sluder4's Avatar
 
Join Date: Dec 2012
Location: Lexington, North Carolina
Region: North Carolina
Posts: 360
Mine did the same thing cause it needed to be aligned and after I got it aligned it stopped.


Sent from my iPhone using Mustang Evolution
__________________
1999 V6 Mustang Dark Satin Green , SR CAI, BBK 65mm Throttle Body, Screaming Demon Coil Pack, SR Lowering Springs, Pioneer Stereo, 2 12' inch subs and 1600watt amp, Green Calipers,
Sluder4 is offline   Reply With Quote
Old 07-24-2014, 07:27 PM   #3
Registered Member
Regular
 
Sketchificus's Avatar
 
Join Date: Mar 2014
Posts: 36
Definitely check your ball joints dude. My car used to make the most awful screech when turning, hitting bumps and the like. Although I haven't had them changed, the noise is still there but very subtle

Sent from my XT1080 using Mustang Evolution mobile app
Sketchificus is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-28-2014, 04:08 PM   #4
Registered User
Newbie
 
Stang_life3's Avatar
 
Join Date: May 2014
Location: Charlotte
Region: North Carolina
Posts: 7
I still haven't figured out what it is. I got the front ball joints on both sides replaced but still no luck. I drove it to the beach which is about 3 hours from where I live. The whole way there it mad the noise. On the way back it didn't make the noise at all and for about a week it didn't make any noise. Then all of a sudden it came back about 2 days ago. I have no clue what it is.


Sent from my iPhone using Mustang Evolution
Stang_life3 is offline   Reply With Quote
Old 07-28-2014, 05:06 PM   #5
Registered Member
Regular
 
Sketchificus's Avatar
 
Join Date: Mar 2014
Posts: 36
Hmm. Well it's definitely got something to do with suspension components. Maybe some bushings somewhere in the front? Sway bar? Idk I thought for sure it'd be ball joints dude

Sent from my XT1080 using Mustang Evolution mobile app
Sketchificus is offline   Reply With Quote
Old 07-28-2014, 05:20 PM   #6
Registered User
Newbie
 
Stang_life3's Avatar
 
Join Date: May 2014
Location: Charlotte
Region: North Carolina
Posts: 7
I'm pretty sure it's coming from the rear. Now that it has been making the noise for a while it sounds worse. It's definitely coming from the rear and it's not only when I turn left now. It makes the noise the worst when I begin rolling forward at a stop light and when I turn left in parking lots. When I get above 40 it doesn't make any noise until I slow it down.


Sent from my iPhone using Mustang Evolution
Stang_life3 is offline   Reply With Quote
Old 01-31-2015, 08:12 PM   #7
Registered Member
Regular
 
Join Date: Jan 2015
Posts: 50
Sounds like hub or axel bearings
Have you checked either?


Sent from my iPhone using Mustang Evolution
tsteevs_foxbody is offline   Reply With Quote
Old 02-05-2015, 05:44 AM   #8
Registered Member
Regular
 
Jaytraeg's Avatar
 
Join Date: Dec 2013
Location: Merrill
Region: Wisconsin
Posts: 96
Might be a bad brake pad that's rubbing. When's the last time you had brake work done? Otherwise I know from experience that bad tie rods can do that too, but it sounds like you already replaced those.
Jaytraeg is offline   Reply With Quote
Old 02-05-2015, 10:30 AM   #9
Registered Member
Regular
 
Darth Paul's Avatar
 
Join Date: Sep 2014
Location: Chubsey
Region: Tennessee
Posts: 126
Don't turn left


Sent from somewhere near the center of the Milky Way
Darth Paul is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is the screeching noise coming from my front end??? Stang_life3 Pre-2005 V6 Mustang 0 06-23-2014 06:22 PM
What is the screeching noise coming from my front end??? Stang_life3 General Mustang Discussion 0 06-23-2014 12:36 PM
Air condition making loud noise when i turn it on Shark3y 1996-2004 Mustang GT 2 07-29-2013 07:34 PM
96 mustang making loud screeching noise from engine.. HELP! Justin96 1996-2004 Mustang GT 1 02-08-2013 06:51 PM
screeching noise vinnygt 1996-2004 Mustang GT 27 07-08-2011 11:14 AM

» Like Us On Facebook



02:04 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.