Taillights look weird - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-26-2014, 06:12 PM   #1
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Taillights look weird

Yesterday I had a buddy record my car from the rear and I noticed the right taillight doesn't seem to have all the lil dots lit up if u know wat I mean. I put 3 new bulbs thinking it was dying out and that's why all the dots weren't lighting up but nothing has changed, here's an example of wat I mean
Click image for larger version

Name:	ImageUploadedByMustang Evolution1403824341.483723.jpg
Views:	101
Size:	380.4 KB
ID:	160124Click image for larger version

Name:	ImageUploadedByMustang Evolution1403824349.836947.jpg
Views:	100
Size:	437.5 KB
ID:	160125
Do I need new taillights


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-26-2014, 09:35 PM   #2
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Turn the headlights off and check to see what it looks like. It may be an issue with the bulbs not making good connection or you could have a wiring issue. Are you running a sequential light setup at all?
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-26-2014, 09:54 PM   #3
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Yea I do have the sequential setup,


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-26-2014, 10:03 PM   #4
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Quote:
Originally Posted by comporange View Post
Yea I do have the sequential setup,


Sent from my iPhone using Mustang Evolution
Is it the plug and play or the splice in kit?
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-26-2014, 10:08 PM   #5
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Umm I think splice I really don't know it was on the car when I got it, why is there sumthing in that which is causing the problem maybe


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Old 06-26-2014, 10:14 PM   #6
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
That would be the first thing I would check out
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-26-2014, 10:18 PM   #7
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Yea I'll check that out this weekend... I was just going to buy AM smoked tailights


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Old 06-26-2014, 11:39 PM   #8
Road Trip!
Regular
 
Join Date: May 2013
Location: Phoenix, Az
Region: Arizona
Posts: 1,037
Check the wires bro. Looks like 2/3 bulbs aren't on (at least to me) I got a cheap splice kit from ebay and my pass side always gives me problems where the inner light only blinks
Joser714 is offline   Reply With Quote
Old 06-27-2014, 05:01 AM   #9
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Ok Kool thanks bro I'm Check it out today when I get off wrk


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Old 06-27-2014, 09:53 AM   #10
Site Sponsor
 
Join Date: May 2014
Location: Malvern, PA
Region: Pennsylvania
Posts: 2,510
Quote:
Originally Posted by Mile high JDF View Post
That would be the first thing I would check out
OP-I would definitely pull and have it reinstalled-If it's still persisting let us know so we can take a closer look and if need be have it replaced for you no questions asked!

-Alex
__________________
Alex Lazarus | AmericanMuscle.com
Toll Free: 1-866-363-4591
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A SUPERCHARGED MUSTANG & 2017 RAPTOR!
Free Same-Day Shipping!
AMAlexLazarus is offline   Reply With Quote
Old 06-27-2014, 12:56 PM   #11
Registered Member
Regular
 
RJ13GT's Avatar
 
Join Date: May 2014
Location: Roanoke Rapids
Region: North Carolina
Posts: 157
There is a reflective material inside the tail lights sometimes it doesnt focus the light exactly right. Might be warped a little or something.

Sent from my SCH-S720C using Tapatalk 2
__________________
2013 5.0, Black, Auto, Procharger P1SC stg 2, 4.13'' pulley(8 psi), JMS bap, 3'' x pipe, Circle D 3c, Kooks axleback, BMR control arms. 593rwhp
RJ13GT is offline   Reply With Quote
Old 06-27-2014, 09:31 PM   #12
Registered Member
Regular
 
V6 stang's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 2,252
Those splice kits typically don't work that well. They either cut through the wire, or don't cut far enough. They also cause issues if they move much. I'm betting it's within the splice. Hopefully it didn't cut through.
__________________
"Hp sells cars, Tq wins races" - Carroll Shelby... RIP
2012 Mustang GT Convertible
Roush Exhaust

2003 Mustang GT (Sold)
1999 35th Anniversary V6(SOLD)
V6 stang is offline   Reply With Quote
Old 06-28-2014, 05:48 PM   #13
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
Yea I hope not if so I'm get the plug and play version


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Am Raxiom Smoked Fog Lights? Look Weird? galindojr24 2005-2010 Mustang GT 9 02-24-2013 01:31 PM
does it look weird? JKZ 2005-2010 Mustang GT 3 10-10-2012 02:26 PM
So you think mustangs look like 4x4's stock eh? look here sonic04edge Pictures and Videos 10 04-29-2005 05:14 PM
OMG.. WEIRD.. so weird.. wiarumas The Bar 14 02-17-2005 01:45 PM
LOL... look what my stang used to look like.... omfg Zim The Bar 12 10-29-2003 07:32 PM

» Like Us On Facebook



02:13 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.