Battery keeps on needing to be jump started. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-01-2014, 07:00 PM   #1
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Battery keeps on needing to be jump started.

The battery is 1 year old in November.
The alternator was rebuilt 3 months ago.
When I took my car to autozone to get it checked, the battery read as OK and the alternator was tested at 12.7 volts or something, the tech suggested I have it checked.

The car is on "vacation" so to speak since we're not driving it as much. It'll go a day or two without being driven.

Today the car was taken out a couple hours ago, when I get home I go to turn it on and check and the battery is dead. This isn't the first time it happened.

The battery has lost charge 3+ or so times before this summer for various reasons; I wasn't aware that leaving the doors open while figuring out leaks etc during the day would discharge it, stuff like that. I removed the rear quarter panels, the rear speakers, disconnected the rear window cables when I was trying to figure out why water got in. Figured it out, put everything back, the speakers/windows were plugged back in correctly since they operate normally. The convertible motor and everything is all plugged in.

The only electrical thing i've changed were the dome lights to LEDs early last month but it doesnt seem to cause it. The speakers on the bottom of the doors in the front (mach 460, the ones that do all the bass) do crackle and short sometimes when it rains as water drops get in thru the door and it's on until they dry.

My dad says maybe something is disconnected and causing the battery to lose charge but everything I messed with is connected. I'm opening the rear again tomorrow to double check.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2014, 07:05 PM   #2
Registered Member
Regular
 
comporange's Avatar
 
Join Date: Sep 2013
Location: glen burnie
Region: Maryland
Posts: 880
This may sound crazy but check your mass airflow sensor, something very similar to your situation happened to me a few months ago and I went thru all the hassle to find out the MAF wasn't connected. I though it was my battery and Alternator also. It would lose power while I was driving and everything


Sent from my iPhone using Mustang Evolution
comporange is offline   Reply With Quote
Old 07-01-2014, 07:07 PM   #3
Registered Member
Regular
 
Join Date: Jun 2014
Location: Parniak
Region: Wisconsin
Posts: 618
anything plugged into your cig lighter or power port?
on your battery, some have a clear circle on top you can look into. If its red your battery is junk green your okay. MY battery was the the same, if the car wasn't driven everyday it was dead. After a battery has died and been jumped a few times its basically never going to be the same again.
TurboCobra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2014, 07:15 PM   #4
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
The MAF is connected.

My cig lighter stopped working last year when we accidentally shorted it removing my center console. This battery (duralast) doesn't have a clear circle.

---------- Post added at 06:15 PM ---------- Previous post was at 06:14 PM ----------

The MAF is connected.

My cig lighter stopped working last year when we accidentally shorted it removing my center console. This battery (duralast) doesn't have a clear circle.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 07-01-2014, 08:02 PM   #5
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
We gave up trying to jump start it, so we put it in neutral to move it aside, power steering was gone, brake pedal was hard. When I was in the car forcing the wheel to the side all the lights in the car dimmed and lost power. Alternator?


Sent from my iPhone using Mustang Evolution
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 07-01-2014, 11:42 PM   #6
Road Trip!
Regular
 
Join Date: May 2013
Location: Phoenix, Az
Region: Arizona
Posts: 1,037
The connections clean?
Joser714 is offline   Reply With Quote
Old 07-02-2014, 07:00 AM   #7
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Yes they are.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 07-03-2014, 06:54 AM   #8
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
After putting a spare battery we had around, we jumpstarted it as it was left for a month. In about like 2 hours we check the car, dead again. This time jump start and we left the car idling for a good while. While the car was idling around I went and googled. Parasitic drain from my mach 460? I disconnected the rear amps and went to the little fuse box under the steering wheel and removed fuses 9 and 27. This morning the car has battery but we'll see.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new battery keeps dying over night. 88GHOSTFOX 1979-1995 Mustang GT 10 08-12-2013 08:29 PM
Battery keeps dying Nwg20 1979-1995 Mustang GT 22 03-22-2013 04:47 AM
A/C will make it JUMP, JUMP! daddydigest 1996-2004 Mustang GT 5 08-16-2012 07:01 AM
some body jump on this STEVE The Bar 13 10-08-2004 05:52 PM

» Like Us On Facebook



12:13 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.