Trying to pin this down. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-08-2014, 04:21 PM   #1
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Trying to pin this down.

2004 V6.
Acceleration issues:
-Poor acceleration
-RPM drop while accelerating
-RPM drop when going from Park to Drive or to Reverse
-Hesitation

Spark plugs are recent, as in less than 3-4 months old. Spark plug wires were changed yesterday as two were damaged. Ignition coil was replaced at 145k.
My CAI's filter is sorta bent up since I didnt tighten it all the way after cleaning it once and it fell off near the house and I drove over it. Maybe that's affecting air flow or something.

I have cleaners for both the MAF and TB waiting for when I have time.. but is there anything else I should be looking at?
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2014, 08:33 PM   #2
Registered Member
Regular
 
misterpancho95's Avatar
 
Join Date: Apr 2014
Posts: 92
Have you checked the vacuum hoses, I know when I swapped upper intakes it would do the same and it was just a bad vacuum hose.

Sent from my HTC0P3P7 using Mustang Evolution mobile app
misterpancho95 is offline   Reply With Quote
Old 10-08-2014, 08:36 PM   #3
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Quote:
Originally Posted by misterpancho95 View Post
Have you checked the vacuum hoses, I know when I swapped upper intakes it would do the same and it was just a bad vacuum hose.

Sent from my HTC0P3P7 using Mustang Evolution mobile app
How many hoses are there and where? I know one connects to the air intake
-Cleaned TB, doesn't seem like there's any change. I did forget to mention I have an exhaust leak before the o2 sensors, so I'll have to investigate that. Apparently causes car to run lean and exhibit above symptoms
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-09-2014, 05:22 PM   #4
Registered Member
Regular
 
misterpancho95's Avatar
 
Join Date: Apr 2014
Posts: 92
Yeah sometimes, and there is one on the passenger behind the pcv that is connected to a plastic barb, and there's also the pcv's are you running breathers from the from the pcv holes on both sides or are you still using the vacuum hoses. I remember I was running breathers and one came out and my car just wanted to die and it would rev up and rev down

Sent from my 831C using Mustang Evolution mobile app
misterpancho95 is offline   Reply With Quote
Old 10-10-2014, 09:58 AM   #5
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
I haven't added/done anything to the vacuum system so I'm assuming I'm using hoses.
The TB clean did fix that rpm drop from park to whatever, though. Later I'm going to clean the maf and see where it takes me. I have a laundry list of things to do, next is replacing my drivers exhaust manifold to address the leak.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 10-10-2014, 11:34 AM   #6
Registered Member
Regular
 
misterpancho95's Avatar
 
Join Date: Apr 2014
Posts: 92
Well if that worked keep doing that good luck miri

Sent from my 831C using Mustang Evolution mobile app
misterpancho95 is offline   Reply With Quote
Old 10-12-2014, 09:50 AM   #7
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Thanks Pancho. I feel like the maf cleaning helped some. I'll just continue posting things as I get them done
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 10-15-2014, 08:36 PM   #8
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Bought exhaust manifold. Installing this weekend.
Car didn't react well at all to custom tunes; performance tune had the car with way worse hesitation (but under all that I could feel the performance increase)
Economy tune caused a grinding noise on acceleration which stopped once I went back to stock. Doing datalogs for tuners in the morning so they can see. He suspects it could be the CAI throwing the car off.

Could I be lean? I'm googling for how a car reacts to being lean and it's all "remove your spark plugs and see", i'm not trying to remove spark plugs right now, afraid of breaking a wire. Old plugs weren't white or anything though.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 10-17-2014, 10:28 AM   #9
Registered Member
Regular
 
IWstangboy03v6's Avatar
 
Join Date: May 2014
Posts: 112
Clean your MAF of you haven't done so. My car was dropping idle so I cleaned the maf. It got a lot better and my check engine light went off

Sent from my XT1080 using Mustang Evolution mobile app
IWstangboy03v6 is offline   Reply With Quote
Old 10-17-2014, 04:02 PM   #10
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
I did clean MAF.
Changing exhaust manifold... it's unpleasant to say the least. Placing the new one is difficult.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Old 10-18-2014, 09:07 PM   #11
Registered Member
Regular
 
Join Date: May 2014
Location: Miami
Region: Florida
Posts: 112
Dear diary,
when replacing exhaust manifolds loosen the other manifold at the midpipe to allow for clearance to place the new one. It's so nice not having the car go HEY HI EVERYONE TICK TICK TICK TICK every time I turn it on, but now at the midpipe on the passenger side it seems there's a teeny tiny leak, ill address it some other day. The car seems more lively. I bought Marvel Mystery Oil and I put some in when I got gas today, next week i'm changing the fuel and CAI filter... Past those two, there is compression test, and tranny fluid change.

Feel free to throw suggestions/ideas at me.
__________________
"Joey" 2004 v6: SR CAI, MPT Tuned, 4.10 gears
Miri is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
easy way to take of pin stripe? blackonblack Mustang Audio & Video 7 05-02-2010 11:07 AM
notched cross pin sonicpony03 Pre-2005 V6 Mustang 9 01-05-2009 08:00 PM
You could of heard a pin drop sonic04edge The Bar 8 08-20-2008 11:43 PM

» Like Us On Facebook



05:47 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.