My 01 mustang - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-23-2014, 09:45 PM   #1
Registered User
Newbie
 
Join Date: Nov 2014
Posts: 1
My 01 mustang

Im baffled by my car at cruising speeds it has a misfire but aint my plugs. I think its the transmission it is like it is goin from 2grand to 3.5 rpms and shifting hard. And the overdrive light goes off and on. Is there any tips to offer as far as diy? And how many vacuum lines are there? And is it possible


Sent from my SAMSUNG-SGH-I547 using Mustang Evolution mobile app
skipper87 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-07-2014, 06:08 PM   #2
Registered Member
Regular
 
Jmustang78's Avatar
 
Join Date: Oct 2014
Location: Billings
Region: Montana
Posts: 132
Send a message via Yahoo to Jmustang78
Check to see if the switch on ur shifter is bad


Sent from my iPad using Mustang Evolution
Jmustang78 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.