Odometer - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-13-2015, 05:05 PM   #1
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 21
Odometer

Ok so my odometer stopped working, and in 94 _98 mustang the gears strip around 130000 . So I replaced it no problem. It worked for about 3 miles then stopped. Any idea why?

Sent from my Z970 using Mustang Evolution mobile app
Attached Thumbnails
Click image for larger version

Name:	1426284309994.jpg
Views:	44
Size:	56.7 KB
ID:	177337  
grim25 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2015, 11:36 AM   #2
Registered Member
Regular
 
phatmike's Avatar
 
Join Date: Aug 2014
Location: Omaha
Region: Nebraska
Posts: 42
Did you make sure to snap the driven gear into place? I don't see how something would've actually snapped after 3 miles..
phatmike is offline   Reply With Quote
Old 03-14-2015, 12:07 PM   #3
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 21
I thought I did I felt it pop in. Could the motor have burned up

Sent from my Z970 using Mustang Evolution mobile app
grim25 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2015, 12:47 PM   #4
Registered Member
Regular
 
phatmike's Avatar
 
Join Date: Aug 2014
Location: Omaha
Region: Nebraska
Posts: 42
What I would do is take out the whole assembly again and check for any broken pieces on the driven gear and make sure you left about a thumb nails width between the worm gear and the motor and also make sure you removed all of the old broken pieces from your old gears. You might as well check the motor while you're in there too
phatmike is offline   Reply With Quote
Old 03-14-2015, 02:08 PM   #5
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 21
Maybe it's the worm gear ,cause I didn't leave space between

Sent from my Z970 using Mustang Evolution mobile app

---------- Post added at 07:08 PM ---------- Previous post was at 07:08 PM ----------

Thanks phatmike

Sent from my Z970 using Mustang Evolution mobile app
grim25 is offline   Reply With Quote
Old 03-16-2015, 02:57 PM   #6
Registered Member
Regular
 
Join Date: Mar 2015
Posts: 21
Well wasn't the worm gear made sure there was space cogs were pushed all the way in. Still not working

Sent from my Z970 using Mustang Evolution mobile app
grim25 is offline   Reply With Quote
Old 03-16-2015, 03:34 PM   #7
Registered Member
Regular
 
phatmike's Avatar
 
Join Date: Aug 2014
Location: Omaha
Region: Nebraska
Posts: 42
Then the only thing I can think of is a bad motor/bad wiring
phatmike is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does your Odometer read? DarkShadow General Car Discussion 54 06-18-2007 10:53 PM
Speedo/Odometer Gears floridamba Pre-2005 V6 Mustang 5 05-01-2007 09:32 AM
Speedo works, Odometer does not.. floridamba Pre-2005 V6 Mustang 9 04-24-2007 04:02 AM
Odometer Stopped Turning Brent Pre-2005 V6 Mustang 7 09-14-2006 10:24 AM
post pics of your odometer cluster maximus Mustang Audio & Video 16 08-02-2006 10:34 PM

» Like Us On Facebook



11:45 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.